aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Alien-SDL
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-07 16:35:50 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-07 16:35:50 +0000
commit8928eb6dc4a7a5aa423c306a93225ae767726736 (patch)
tree5ae34269b964f4df900c811c4843c49ea3e3b6ca /devel/p5-Alien-SDL
parent4debbc7ab535d4680210b33683c13b00ddbdcc7c (diff)
Notes
Diffstat (limited to 'devel/p5-Alien-SDL')
-rw-r--r--devel/p5-Alien-SDL/Makefile25
-rw-r--r--devel/p5-Alien-SDL/distinfo2
-rw-r--r--devel/p5-Alien-SDL/pkg-descr4
-rw-r--r--devel/p5-Alien-SDL/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-Alien-SDL/Makefile b/devel/p5-Alien-SDL/Makefile
new file mode 100644
index 000000000000..9ee3b5803d33
--- /dev/null
+++ b/devel/p5-Alien-SDL/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= Alien-SDL
+PORTVERSION= 1.440
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Detect and get configuration setting for SDL
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-Text-Patch>=1.4:${PORTSDIR}/textproc/p5-Text-Patch
+RUN_DEPENDS= p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny
+
+USES= perl5
+USE_PERL5= modbuild
+USE_SDL= gfx image mixer pango sdl ttf
+CONFIGURE_ARGS= --with-sdl-config=${SDL_CONFIG}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Alien-SDL/distinfo b/devel/p5-Alien-SDL/distinfo
new file mode 100644
index 000000000000..1b4c54f19169
--- /dev/null
+++ b/devel/p5-Alien-SDL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Alien-SDL-1.440.tar.gz) = cc25c9319d2db984b049eed5559582b2a6e0072af9b48d621a7772a1dcd18961
+SIZE (Alien-SDL-1.440.tar.gz) = 346309
diff --git a/devel/p5-Alien-SDL/pkg-descr b/devel/p5-Alien-SDL/pkg-descr
new file mode 100644
index 000000000000..a2ec615111e1
--- /dev/null
+++ b/devel/p5-Alien-SDL/pkg-descr
@@ -0,0 +1,4 @@
+Alien::SDL can be used to detect and get configuration settings
+from an installed SDL and related libraries.
+
+WWW: http://search.cpan.org/dist/Alien-SDL/
diff --git a/devel/p5-Alien-SDL/pkg-plist b/devel/p5-Alien-SDL/pkg-plist
new file mode 100644
index 000000000000..18a733145aa0
--- /dev/null
+++ b/devel/p5-Alien-SDL/pkg-plist
@@ -0,0 +1,7 @@
+bin/sdl-config.pl
+%%PERL5_MAN3%%/Alien::SDL.3.gz
+%%PERL5_MAN3%%/Alien::SDL::ConfigData.3.gz
+%%SITE_PERL%%/Alien/SDL.pm
+%%SITE_PERL%%/Alien/SDL/ConfigData.pm
+@dirrmtry %%SITE_PERL%%/Alien/SDL
+@dirrmtry %%SITE_PERL%%/Alien