aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Alzabo-GUI-Mason
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-13 14:09:33 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-13 14:09:33 +0000
commitd8dd6d5d8626f31f9078522758eb394d28368422 (patch)
tree7e5ef6bbe0443207372ce319f702d145b54ffec0 /devel/p5-Alzabo-GUI-Mason
parentf71d266547c3b85926c55361da57405a8f2ad3b0 (diff)
downloadports-d8dd6d5d8626f31f9078522758eb394d28368422.tar.gz
ports-d8dd6d5d8626f31f9078522758eb394d28368422.zip
Notes
Diffstat (limited to 'devel/p5-Alzabo-GUI-Mason')
-rw-r--r--devel/p5-Alzabo-GUI-Mason/Makefile47
-rw-r--r--devel/p5-Alzabo-GUI-Mason/distinfo2
-rw-r--r--devel/p5-Alzabo-GUI-Mason/files/patch-Build.PL35
-rw-r--r--devel/p5-Alzabo-GUI-Mason/files/patch-inc-Alzabo-GUI-Mason-Build.pm40
-rw-r--r--devel/p5-Alzabo-GUI-Mason/pkg-descr4
-rw-r--r--devel/p5-Alzabo-GUI-Mason/pkg-plist54
6 files changed, 182 insertions, 0 deletions
diff --git a/devel/p5-Alzabo-GUI-Mason/Makefile b/devel/p5-Alzabo-GUI-Mason/Makefile
new file mode 100644
index 000000000000..99b17595cd6e
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Alzabo-GUI-Mason
+# Date created: 13 Oct 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Alzabo-GUI-Mason
+PORTVERSION= 0.1
+CATEGORIES= devel databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Alzabo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A GUI for Alzabo using Mason
+
+BUILD_DEPENDS= ${SITE_PERL}/Alzabo.pm:${PORTSDIR}/devel/p5-Alzabo \
+ ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
+ ${SITE_PERL}/HTTP/BrowserDetect.pm:${PORTSDIR}/www/p5-HTTP-BrowserDetect
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+CONFIGURE_ENV= DATADIR=${DATADIR}
+MAKE_ENV= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
+MAN3= Alzabo::GUI::Mason.3 Alzabo::GUI::Mason::Config.3
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+pre-install:
+ @${MKDIR} ${DATADIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Needs perl 5.6+, install lang/perl5 or lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Alzabo-GUI-Mason/distinfo b/devel/p5-Alzabo-GUI-Mason/distinfo
new file mode 100644
index 000000000000..66bd734fbef5
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/distinfo
@@ -0,0 +1,2 @@
+MD5 (Alzabo-GUI-Mason-0.1.tar.gz) = 545d66e8ede79987c2e260f510efcf5f
+SIZE (Alzabo-GUI-Mason-0.1.tar.gz) = 42969
diff --git a/devel/p5-Alzabo-GUI-Mason/files/patch-Build.PL b/devel/p5-Alzabo-GUI-Mason/files/patch-Build.PL
new file mode 100644
index 000000000000..8df19d618ee1
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/files/patch-Build.PL
@@ -0,0 +1,35 @@
+--- Build.PL~ Wed Feb 18 19:54:38 2004
++++ Build.PL Wed Oct 13 15:37:16 2004
+@@ -45,8 +45,6 @@
+ my $default = $config->{mason_web_dir};
+ $default =~ s,/alzabo\Z,, if $default;
+
+- do
+- {
+ print "\n *** The directory you selected does not exist ***\n"
+ if defined $config->{mason_web_dir} && ! -d $config->{mason_web_dir};
+
+@@ -61,11 +59,7 @@
+ server's document root will work.
+ EOF
+
+- $config->{mason_web_dir} =
+- Module::Build->prompt( ' Mason directory?', $default || '' );
+- } while ( ! -d $config->{mason_web_dir} );
+-
+- $config->{mason_web_dir} = File::Spec->catdir( $config->{mason_web_dir}, 'alzabo' );
++ $config->{mason_web_dir} = $ENV{DATADIR};
+
+ print <<'EOF';
+
+@@ -76,9 +70,7 @@
+ EOF
+
+
+- $config->{mason_extension} =
+- Module::Build->prompt( ' Mason component file extension?',
+- $config->{mason_extension} || '.mhtml' );
++ $config->{mason_extension} = '.mhtml';
+
+ write_config_module($config);
+ }
diff --git a/devel/p5-Alzabo-GUI-Mason/files/patch-inc-Alzabo-GUI-Mason-Build.pm b/devel/p5-Alzabo-GUI-Mason/files/patch-inc-Alzabo-GUI-Mason-Build.pm
new file mode 100644
index 000000000000..b6224436db6a
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/files/patch-inc-Alzabo-GUI-Mason-Build.pm
@@ -0,0 +1,40 @@
+--- inc/Alzabo/GUI/Mason/Build.pm~ Wed Feb 18 19:54:38 2004
++++ inc/Alzabo/GUI/Mason/Build.pm Wed Oct 13 15:39:43 2004
+@@ -25,12 +25,10 @@
+ {
+ my $self = shift;
+
+- $self->_make_mason_dirs( 'schema' );
+-
+ require Alzabo::GUI::Mason::Config;
+ my $base = Alzabo::GUI::Mason::Config::mason_web_dir();
+ my $count = $self->_copy_dir( [ cwd(), 'mason' ],
+- [ $base, 'schema' ] );
++ [ $base ] );
+ if ($count)
+ {
+ warn <<'EOF';
+@@ -123,21 +121,9 @@
+ return if ( exists $self->{Alzabo}{uid} &&
+ exists $self->{Alzabo}{gid} );
+
+- $self->{Alzabo}{user} =
+- $self->prompt( <<'EOF',
+-
+-What user would you like to own the directories and files used for the
+-Mason components as well as the components themselves?
+-EOF
+- $self->_possible_web_user );
++ $self->{Alzabo}{user} = $ENV{WWWOWN};
+
+- $self->{Alzabo}{group} =
+- $self->prompt( <<'EOF',
+-
+-What group would you like to own the directories and files used for
+-the Mason components as well as the components themselves?
+-EOF
+- $self->_possible_web_group );
++ $self->{Alzabo}{group} = $ENV{WWWGRP};
+
+ $self->{Alzabo}{uid} = (getpwnam( $self->{Alzabo}{user} ))[2] || $<;
+ $self->{Alzabo}{gid} = (getgrnam( $self->{Alzabo}{group} ))[2] || $(;
diff --git a/devel/p5-Alzabo-GUI-Mason/pkg-descr b/devel/p5-Alzabo-GUI-Mason/pkg-descr
new file mode 100644
index 000000000000..c3d43d9b70fc
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/pkg-descr
@@ -0,0 +1,4 @@
+This package contains a data modelling GUI for Alzabo implemented with
+HTML::Mason.
+
+WWW: http://search.cpan.org/dist/Alzabo-GUI-Mason/
diff --git a/devel/p5-Alzabo-GUI-Mason/pkg-plist b/devel/p5-Alzabo-GUI-Mason/pkg-plist
new file mode 100644
index 000000000000..b1510e8b0457
--- /dev/null
+++ b/devel/p5-Alzabo-GUI-Mason/pkg-plist
@@ -0,0 +1,54 @@
+%%SITE_PERL%%/Alzabo/GUI/Mason.pm
+%%SITE_PERL%%/Alzabo/GUI/Mason/Config.pm
+%%DATADIR%%/add_column.mhtml
+%%DATADIR%%/add_index_1.mhtml
+%%DATADIR%%/add_index_2.mhtml
+%%DATADIR%%/add_relationship.mhtml
+%%DATADIR%%/add_relationship_2.mhtml
+%%DATADIR%%/add_table.mhtml
+%%DATADIR%%/alzabo.css
+%%DATADIR%%/autohandler
+%%DATADIR%%/change_column.mhtml
+%%DATADIR%%/change_column_name.mhtml
+%%DATADIR%%/change_schema_instantiation.mhtml
+%%DATADIR%%/change_schema_name.mhtml
+%%DATADIR%%/change_table_attributes.mhtml
+%%DATADIR%%/change_table_comment.mhtml
+%%DATADIR%%/change_table_name.mhtml
+%%DATADIR%%/cube_logo.jpg
+%%DATADIR%%/delete_column.mhtml
+%%DATADIR%%/delete_foreign_key.mhtml
+%%DATADIR%%/delete_index.mhtml
+%%DATADIR%%/delete_schema.mhtml
+%%DATADIR%%/delete_schema_confirm.mhtml
+%%DATADIR%%/delete_table.mhtml
+%%DATADIR%%/draw_graph.mhtml
+%%DATADIR%%/exception
+%%DATADIR%%/execute_sql.mhtml
+%%DATADIR%%/execute_sync_sql.mhtml
+%%DATADIR%%/handle_rules_exception
+%%DATADIR%%/href
+%%DATADIR%%/hyena.jpg
+%%DATADIR%%/index.mhtml
+%%DATADIR%%/login_form.mas
+%%DATADIR%%/make_url
+%%DATADIR%%/move_column.mhtml
+%%DATADIR%%/move_table.mhtml
+%%DATADIR%%/new_schema.mhtml
+%%DATADIR%%/redirect
+%%DATADIR%%/reverse_engineer.mhtml
+%%DATADIR%%/schema_menubar
+%%DATADIR%%/syshandler
+%%DATADIR%%/table_menubar
+%%DATADIR%%/url
+%%DATADIR%%/view_column.mhtml
+%%DATADIR%%/view_graph.mhtml
+%%DATADIR%%/view_schema.mhtml
+%%DATADIR%%/view_schema_sql.mhtml
+%%DATADIR%%/view_sync_sql.mhtml
+%%DATADIR%%/view_table.mhtml
+%%DATADIR%%/view_table_other.mhtml
+@dirrm %%DATADIR%%
+@dirrm %%SITE_PERL%%/Alzabo/GUI/Mason
+@unexec rmdir %D/%%SITE_PERL%%/Alzabo/GUI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Alzabo 2>/dev/null || true