aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-App-CLI/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-27 09:26:13 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-27 09:26:13 +0000
commit0f816f5f032703ab92b175e26de8ac6e515247c1 (patch)
tree9bc1311e306e649841d6e6721f69100600382399 /devel/p5-App-CLI/Makefile
parent2d128fb816eb7bf8cb66f5e148ef5a8f45abb9a2 (diff)
Notes
Diffstat (limited to 'devel/p5-App-CLI/Makefile')
-rw-r--r--devel/p5-App-CLI/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-App-CLI/Makefile b/devel/p5-App-CLI/Makefile
new file mode 100644
index 000000000000..155c2e8b2352
--- /dev/null
+++ b/devel/p5-App-CLI/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-App-CLI
+# Date created: 27 Dec 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-CLI
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= App
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= App::CLI - Dispatcher module for command line interface programs
+
+BUILD_DEPENDS= \
+ p5-Locale-Maketext-Simple>0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ p5-Pod-Simple>0:${PORTSDIR}/textproc/p5-Pod-Simple \
+ p5-Getopt-Long>=2.34:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= App::CLI.3 \
+ App::CLI::Command.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>