aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-App-GitGot/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-05 12:59:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-06-05 12:59:10 +0000
commit3e7a5152430f8a2812d7c8739e28133f8a97c607 (patch)
tree82233a69285c6a61602294669c5b19f4d47af850 /devel/p5-App-GitGot/Makefile
parentb6ba6da3576d1f2bf4b5f50e9a55c6b5cc0da9e0 (diff)
Notes
Diffstat (limited to 'devel/p5-App-GitGot/Makefile')
-rw-r--r--devel/p5-App-GitGot/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/p5-App-GitGot/Makefile b/devel/p5-App-GitGot/Makefile
index cbb2a368f7b5..89bcbd9ae583 100644
--- a/devel/p5-App-GitGot/Makefile
+++ b/devel/p5-App-GitGot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= App-GitGot
-PORTVERSION= 0.9.2
+PORTVERSION= 1.0
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:GENEHACK
@@ -19,11 +19,14 @@ LICENSE_COMB= dual
LICENSE= ART20 GPLv1
RUN_DEPENDS= p5-Config-INI>=0:${PORTSDIR}/devel/p5-Config-INI \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Git-Wrapper>=0:${PORTSDIR}/devel/p5-Git-Wrapper \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-App-Cmd>=0:${PORTSDIR}/devel/p5-MooseX-App-Cmd \
p5-Net-GitHub>=0:${PORTSDIR}/net/p5-Net-GitHub \
p5-Term-ANSIColor>=0:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
@@ -35,15 +38,21 @@ MAN3= App::GitGot.3 \
App::GitGot::Command.3 \
App::GitGot::Command::add.3 \
App::GitGot::Command::chdir.3 \
+ App::GitGot::Command::clone.3 \
App::GitGot::Command::fork.3 \
+ App::GitGot::Command::gc.3 \
App::GitGot::Command::list.3 \
+ App::GitGot::Command::push.3 \
App::GitGot::Command::remove.3 \
App::GitGot::Command::status.3 \
App::GitGot::Command::update.3 \
+ App::GitGot::Command::update_status.3 \
App::GitGot::Command::version.3 \
App::GitGot::Outputter::dark.3 \
App::GitGot::Outputter.3 \
- App::GitGot::Outputter::light.3
+ App::GitGot::Outputter::light.3 \
+ App::GitGot::Repo.3 \
+ App::GitGot::Repo::Git.3
.include <bsd.port.pre.mk>