aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-App-SVN-Bisect/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-11-05 16:36:10 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-11-05 16:36:10 +0000
commitaffadd16d1185fc8f1320bfb887c10a3a02f5f27 (patch)
tree73da10fe9cb18e12ca0b3fe5a7302d14e36761cf /devel/p5-App-SVN-Bisect/Makefile
parent4cba7c3bd72726e2f48ae28e6d4366ba30e1487a (diff)
downloadports-affadd16d1185fc8f1320bfb887c10a3a02f5f27.tar.gz
ports-affadd16d1185fc8f1320bfb887c10a3a02f5f27.zip
Notes
Diffstat (limited to 'devel/p5-App-SVN-Bisect/Makefile')
-rw-r--r--devel/p5-App-SVN-Bisect/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-App-SVN-Bisect/Makefile b/devel/p5-App-SVN-Bisect/Makefile
new file mode 100644
index 000000000000..d046784a1175
--- /dev/null
+++ b/devel/p5-App-SVN-Bisect/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-App-SVN-Bisect
+# Date created: 5 Nov 2009
+# Whom: Rui Paulo <rpaulo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-SVN-Bisect
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rpaulo@FreeBSD.org
+COMMENT= Binary search through svn revisions
+
+BUILD_DEPENDS= p5-IO-All>0:${PORTSDIR}/devel/p5-IO-All \
+ p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck \
+ ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= svn-bisect.1
+MAN3= App::SVN::Bisect.3
+
+.include <bsd.port.mk>