aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-AppConfig-Std/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-07-25 22:57:50 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-07-25 22:57:50 +0000
commit867df7cdacc44aab0c72575f10ee4c9d9e4ea944 (patch)
treec4a1fb22e54f826da35ddd174bbaa28cfb8b2c4d /devel/p5-AppConfig-Std/Makefile
parent2796925dcbe4105f8ddefe09412d0208d922d0f4 (diff)
downloadports-867df7cdacc44aab0c72575f10ee4c9d9e4ea944.tar.gz
ports-867df7cdacc44aab0c72575f10ee4c9d9e4ea944.zip
Notes
Diffstat (limited to 'devel/p5-AppConfig-Std/Makefile')
-rw-r--r--devel/p5-AppConfig-Std/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-AppConfig-Std/Makefile b/devel/p5-AppConfig-Std/Makefile
new file mode 100644
index 000000000000..f42c46aa9c09
--- /dev/null
+++ b/devel/p5-AppConfig-Std/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-AppConfig-Std
+# Date created: 20 July 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AppConfig-Std
+PORTVERSION= 1.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= AppConfig
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fuyuki@hadaly.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= AppConfig::Std.3
+
+post-patch:
+ ${PERL} -pi -e 's|(VERSION_FROM\s+=>\s+)(.*)(,.*)$$|$$1$$2$$3\nMAN3PODS=>{$$2=>q!\\\$$(INST_MAN3DIR)/${MAN3}!},|;' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>