aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Array-Unique
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-16 03:04:48 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-16 03:04:48 +0000
commitc5b5627371a39daeced6228cf726fdc88538e5b1 (patch)
tree12b705f1219016b6fb67b5b99775fff6e007c62d /devel/p5-Array-Unique
parent8a89576841fe5230fc021d8cece8fa649327a9f9 (diff)
downloadports-c5b5627371a39daeced6228cf726fdc88538e5b1.tar.gz
ports-c5b5627371a39daeced6228cf726fdc88538e5b1.zip
Notes
Diffstat (limited to 'devel/p5-Array-Unique')
-rw-r--r--devel/p5-Array-Unique/Makefile21
-rw-r--r--devel/p5-Array-Unique/distinfo2
-rw-r--r--devel/p5-Array-Unique/pkg-descr16
-rw-r--r--devel/p5-Array-Unique/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Array-Unique/Makefile b/devel/p5-Array-Unique/Makefile
new file mode 100644
index 000000000000..b510219c9686
--- /dev/null
+++ b/devel/p5-Array-Unique/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Array-Unique
+# Date created: 2010-11-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Array-Unique
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Tie-able array that allows only unique values
+
+PERL_CONFIGURE= yes
+
+MAN3= Array::Unique.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Array-Unique/distinfo b/devel/p5-Array-Unique/distinfo
new file mode 100644
index 000000000000..e2fce9633ceb
--- /dev/null
+++ b/devel/p5-Array-Unique/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Array-Unique-0.08.tar.gz) = 3d5440c90c9caa09900868ad2ba5f84ea52e704af8ce3016d8ee0e6173f271d2
+SIZE (Array-Unique-0.08.tar.gz) = 8759
diff --git a/devel/p5-Array-Unique/pkg-descr b/devel/p5-Array-Unique/pkg-descr
new file mode 100644
index 000000000000..c40daa52efdd
--- /dev/null
+++ b/devel/p5-Array-Unique/pkg-descr
@@ -0,0 +1,16 @@
+This package lets you create an array which will allow only one
+occurrence of any value.
+
+In other words no matter how many times you put in 42 it will keep
+only the first occurrence and the rest will be dropped.
+
+You use the module via tie and once you tied your array to this
+module it will behave correctly.
+
+Uniqueness is checked with the 'eq' operator so among other things it
+is case sensitive.
+
+As a side effect the module does not allow undef as a value in the
+array.
+
+WWW: http://search.cpan.org/dist/Array-Unique/
diff --git a/devel/p5-Array-Unique/pkg-plist b/devel/p5-Array-Unique/pkg-plist
new file mode 100644
index 000000000000..86f00446c6dd
--- /dev/null
+++ b/devel/p5-Array-Unique/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/Unique/.packlist
+%%SITE_PERL%%/Array/Unique.pm
+@dirrmtry etc/devd
+@dirrmtry %%SITE_PERL%%/Array
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/Unique
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array