aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Async-MergePoint
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-04 12:18:58 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-04 12:18:58 +0000
commitccf48577fc780772d47988f845b7a1533806d773 (patch)
tree4ca007471c09c7c21691f0622ebdfa049581cc8d /devel/p5-Async-MergePoint
parent6ee43f9478ff133db6d36342e8e50d1c2d9dbb54 (diff)
downloadports-ccf48577fc780772d47988f845b7a1533806d773.tar.gz
ports-ccf48577fc780772d47988f845b7a1533806d773.zip
Notes
Diffstat (limited to 'devel/p5-Async-MergePoint')
-rw-r--r--devel/p5-Async-MergePoint/Makefile28
-rw-r--r--devel/p5-Async-MergePoint/distinfo3
-rw-r--r--devel/p5-Async-MergePoint/pkg-descr16
3 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Async-MergePoint/Makefile b/devel/p5-Async-MergePoint/Makefile
new file mode 100644
index 000000000000..f84aa6a3694f
--- /dev/null
+++ b/devel/p5-Async-MergePoint/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Async-MergePoint2
+# Date created: 2009-08-04
+# Whom: Felippe M. Motta <lippe@shire.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Async-MergePoint
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= johan@stromnet.se
+COMMENT= Perl modules that resynchronise diverged control flow
+
+PERL_CONFIGURE= yes
+
+MAN3= Async::MergePoint.3
+
+PLIST_FILES= %%SITE_PERL%%/Async/MergePoint.pm \
+ %%SITE_PERL%%/mach/auto/Async/MergePoint/.packlist
+
+PLIST_DIRS= %%SITE_PERL%%/mach/auto/Async/MergePoint \
+ %%SITE_PERL%%/mach/auto/Async \
+ %%SITE_PERL%%/Async
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Async-MergePoint/distinfo b/devel/p5-Async-MergePoint/distinfo
new file mode 100644
index 000000000000..5bc63f25357e
--- /dev/null
+++ b/devel/p5-Async-MergePoint/distinfo
@@ -0,0 +1,3 @@
+MD5 (Async-MergePoint-0.03.tar.gz) = f4a6f9a9dc0a1748f503c01893d544cc
+SHA256 (Async-MergePoint-0.03.tar.gz) = 5e31b89c584b0bbacae3632245f16f5ebcfd6091abac87ae1970814d79e6a775
+SIZE (Async-MergePoint-0.03.tar.gz) = 14036
diff --git a/devel/p5-Async-MergePoint/pkg-descr b/devel/p5-Async-MergePoint/pkg-descr
new file mode 100644
index 000000000000..f89300daacd2
--- /dev/null
+++ b/devel/p5-Async-MergePoint/pkg-descr
@@ -0,0 +1,16 @@
+Often in program logic, multiple different steps need to be taken that
+are independent of each other, but their total result is needed before
+the next step can be taken. In synchonous code, the usual approach is
+to do them sequentially.
+
+An asynchronous or event-based program could do this, but if each step
+involves some IO idle time, better overall performance can often be
+gained by running the steps in parallel. A Async::MergePoint object
+can then be used to wait for all of the steps to complete, before
+passing the combined result of each step on to the next stage.
+
+This module was originally part of the IO::Async distribution, but was
+removed under the inspiration of Pedro Melo's Async::Hooks
+distribution, because it doesn't itself contain anything IO-specific.
+
+WWW: http://search.cpan.org/dist/Async-MergePoint/