aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-B-Graph
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-08-01 14:06:30 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-08-01 14:06:30 +0000
commit0c3d0f016a9bbf06db24a56d03741969d0ac408b (patch)
treee9e2ae531133710efeb942c4cbfd92809a1e34e8 /devel/p5-B-Graph
parentfdeab6ae5fca3729b3792fc1061b2b6aebdaa52b (diff)
downloadports-0c3d0f016a9bbf06db24a56d03741969d0ac408b.tar.gz
ports-0c3d0f016a9bbf06db24a56d03741969d0ac408b.zip
Notes
Diffstat (limited to 'devel/p5-B-Graph')
-rw-r--r--devel/p5-B-Graph/Makefile24
-rw-r--r--devel/p5-B-Graph/distinfo1
-rw-r--r--devel/p5-B-Graph/pkg-comment1
-rw-r--r--devel/p5-B-Graph/pkg-descr11
-rw-r--r--devel/p5-B-Graph/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-B-Graph/Makefile b/devel/p5-B-Graph/Makefile
new file mode 100644
index 000000000000..16bb028ee226
--- /dev/null
+++ b/devel/p5-B-Graph/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-B-Graph
+# Date created: 24-Jul-2000
+# Whom: Leo Kim <leo@florida.sarang.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Graph
+PORTVERSION= 0.50
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=B
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leo@florida.sarang.net
+
+USE_PERL5= YES
+MAN3= B::Graph.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-B-Graph/distinfo b/devel/p5-B-Graph/distinfo
new file mode 100644
index 000000000000..168a21169ee9
--- /dev/null
+++ b/devel/p5-B-Graph/distinfo
@@ -0,0 +1 @@
+MD5 (B-Graph-0.50.tar.gz) = 875887e2fec91221704e89f72745a821
diff --git a/devel/p5-B-Graph/pkg-comment b/devel/p5-B-Graph/pkg-comment
new file mode 100644
index 000000000000..b26b031b109d
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-comment
@@ -0,0 +1 @@
+Perl Compiler backend to diagram OP trees
diff --git a/devel/p5-B-Graph/pkg-descr b/devel/p5-B-Graph/pkg-descr
new file mode 100644
index 000000000000..270713f4ab8f
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-descr
@@ -0,0 +1,11 @@
+This module is a layer between the perl-internals-examining parts of
+Malcolm Beattie's perl compiler (the B::* classes) and your favorite
+graph layout tool (currently Dot and VGC are supported, but adding
+others would be easy). It examines the internal structures that perl
+builds to represent your code (OPs and SVs), and generates
+specifications for multicolored boxes and arrows to represent them.
+
+WWW: http://search.cpan.org/search?module=B::Graph
+
+- Leo Kim
+leo@florida.sarang.net
diff --git a/devel/p5-B-Graph/pkg-plist b/devel/p5-B-Graph/pkg-plist
new file mode 100644
index 000000000000..1eb204af74bb
--- /dev/null
+++ b/devel/p5-B-Graph/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/B/Graph.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/B/Graph/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/B/Graph