aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-B-Hooks-EndOfScope/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-02-17 16:46:09 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-02-17 16:46:09 +0000
commit5233ac598d7407d58cddeef18ec403893d3ac2fd (patch)
treed86565a121a5cfac1c8f6ac3d2be2ca75c8b696c /devel/p5-B-Hooks-EndOfScope/Makefile
parentaf63fc437227be5bc0572fd53f762322571554db (diff)
downloadports-5233ac598d7407d58cddeef18ec403893d3ac2fd.tar.gz
ports-5233ac598d7407d58cddeef18ec403893d3ac2fd.zip
Notes
Diffstat (limited to 'devel/p5-B-Hooks-EndOfScope/Makefile')
-rw-r--r--devel/p5-B-Hooks-EndOfScope/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/p5-B-Hooks-EndOfScope/Makefile b/devel/p5-B-Hooks-EndOfScope/Makefile
index d86e42894f85..e807a94adfab 100644
--- a/devel/p5-B-Hooks-EndOfScope/Makefile
+++ b/devel/p5-B-Hooks-EndOfScope/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= B-Hooks-EndOfScope
-PORTVERSION= 0.09
+PORTVERSION= 0.10
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +14,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Execute code after a scope finished compilation
-RUN_DEPENDS= p5-Variable-Magic>=0.31:${PORTSDIR}/devel/p5-Variable-Magic \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Variable-Magic>=0.34:${PORTSDIR}/devel/p5-Variable-Magic \
p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
-BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= B::Hooks::EndOfScope.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.89:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>