aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-B-Hooks-EndOfScope
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2008-10-26 11:31:16 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2008-10-26 11:31:16 +0000
commit8ae7a102bb9e5771411a1e4c19d265de231bbb4e (patch)
treeddb679fe4f92c3fdf501390fe72d4927face2043 /devel/p5-B-Hooks-EndOfScope
parent4d7ea5de54232588c7a5e850a624e6c231e0cb66 (diff)
Notes
Diffstat (limited to 'devel/p5-B-Hooks-EndOfScope')
-rw-r--r--devel/p5-B-Hooks-EndOfScope/Makefile25
-rw-r--r--devel/p5-B-Hooks-EndOfScope/distinfo3
-rw-r--r--devel/p5-B-Hooks-EndOfScope/pkg-descr4
-rw-r--r--devel/p5-B-Hooks-EndOfScope/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-B-Hooks-EndOfScope/Makefile b/devel/p5-B-Hooks-EndOfScope/Makefile
new file mode 100644
index 000000000000..9d04c92819e6
--- /dev/null
+++ b/devel/p5-B-Hooks-EndOfScope/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-B-Hooks-EndOfScope
+# Date created: 26 Oct 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Hooks-EndOfScope
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Execute code after a scope finished compilation
+
+RUN_DEPENDS= p5-Scope-Guard>0:${PORTSDIR}/devel/p5-Scope-Guard \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= B::Hooks::EndOfScope.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-B-Hooks-EndOfScope/distinfo b/devel/p5-B-Hooks-EndOfScope/distinfo
new file mode 100644
index 000000000000..096fc52f05be
--- /dev/null
+++ b/devel/p5-B-Hooks-EndOfScope/distinfo
@@ -0,0 +1,3 @@
+MD5 (B-Hooks-EndOfScope-0.04.tar.gz) = 1705a0643af266ad902f8dda2212dd78
+SHA256 (B-Hooks-EndOfScope-0.04.tar.gz) = a94083963f0c680e0daaeae71ff38c27cff7ae79dff6bb254b6822b21c960e10
+SIZE (B-Hooks-EndOfScope-0.04.tar.gz) = 14775
diff --git a/devel/p5-B-Hooks-EndOfScope/pkg-descr b/devel/p5-B-Hooks-EndOfScope/pkg-descr
new file mode 100644
index 000000000000..f0c3627132e7
--- /dev/null
+++ b/devel/p5-B-Hooks-EndOfScope/pkg-descr
@@ -0,0 +1,4 @@
+This module allows you to execute code when perl finished compiling the
+surrounding scope.
+
+WWW: http://search.cpan.org/dist/B-Hooks-EndOfScope/
diff --git a/devel/p5-B-Hooks-EndOfScope/pkg-plist b/devel/p5-B-Hooks-EndOfScope/pkg-plist
new file mode 100644
index 000000000000..7038ea624a59
--- /dev/null
+++ b/devel/p5-B-Hooks-EndOfScope/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/B/Hooks/EndOfScope.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/EndOfScope/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks/EndOfScope
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Hooks
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B
+@dirrmtry %%SITE_PERL%%/B/Hooks
+@dirrmtry %%SITE_PERL%%/B