aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Best
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-04-03 14:08:26 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-04-03 14:08:26 +0000
commitf17e3fd2f0404ef59117321df96fa4d847bef235 (patch)
tree0634751a2e7b259215bd55df151def29aadd0f99 /devel/p5-Best
parentf69709f0f29c6cff2c558775496a8be582b5c4ab (diff)
Notes
Diffstat (limited to 'devel/p5-Best')
-rw-r--r--devel/p5-Best/Makefile25
-rw-r--r--devel/p5-Best/distinfo3
-rw-r--r--devel/p5-Best/pkg-descr9
-rw-r--r--devel/p5-Best/pkg-plist3
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Best/Makefile b/devel/p5-Best/Makefile
new file mode 100644
index 000000000000..419390ccdb78
--- /dev/null
+++ b/devel/p5-Best/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Best
+# Date created: 03 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Best
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GA/GAAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fallbackable module loader
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Best.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Best/distinfo b/devel/p5-Best/distinfo
new file mode 100644
index 000000000000..511121da2bd6
--- /dev/null
+++ b/devel/p5-Best/distinfo
@@ -0,0 +1,3 @@
+MD5 (Best-0.11.tar.gz) = fad74c878582a2eeb9b2878baad9b79d
+SHA256 (Best-0.11.tar.gz) = e6a7a1a14211de31deddd6d1fe8d900ba726a7edfebee3c5f3eb0be38856166c
+SIZE (Best-0.11.tar.gz) = 28760
diff --git a/devel/p5-Best/pkg-descr b/devel/p5-Best/pkg-descr
new file mode 100644
index 000000000000..09b60fc0dc3d
--- /dev/null
+++ b/devel/p5-Best/pkg-descr
@@ -0,0 +1,9 @@
+Often there are several possible providers of some functionality your
+program needs, but you don't know which is available at the run site.
+For example, one of the modules may be implemented with XS, or not in
+the core Perl distribution and thus not necessarily installed.
+
+Best.pm attempts to load modules from a list, stopping at the first
+successful load and failing only if no alternative was found.
+
+WWW: http://search.cpan.org/dist/Best/
diff --git a/devel/p5-Best/pkg-plist b/devel/p5-Best/pkg-plist
new file mode 100644
index 000000000000..e9fc2751f8ab
--- /dev/null
+++ b/devel/p5-Best/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Best.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Best/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Best