aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Carp-REPL
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-05-09 03:44:23 +0000
committerSteve Wills <swills@FreeBSD.org>2011-05-09 03:44:23 +0000
commita8e3236cb7b2c545de910c7372fafe02f74c8e7d (patch)
tree9a32c3c9da77d505503f583e585983697e981980 /devel/p5-Carp-REPL
parentaf4cb0674a5fc77630e84cdf1f44d7ed34fb6d72 (diff)
downloadports-a8e3236cb7b2c545de910c7372fafe02f74c8e7d.tar.gz
ports-a8e3236cb7b2c545de910c7372fafe02f74c8e7d.zip
Notes
Diffstat (limited to 'devel/p5-Carp-REPL')
-rw-r--r--devel/p5-Carp-REPL/Makefile36
-rw-r--r--devel/p5-Carp-REPL/distinfo2
-rw-r--r--devel/p5-Carp-REPL/pkg-descr3
-rw-r--r--devel/p5-Carp-REPL/pkg-plist10
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Carp-REPL/Makefile b/devel/p5-Carp-REPL/Makefile
new file mode 100644
index 000000000000..27c1d8f6aa6a
--- /dev/null
+++ b/devel/p5-Carp-REPL/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Carp-REPL
+# Date created: 2011-05-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp-REPL
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SARTAK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Read-Eval-Print-Loop on die and/or warn
+
+BUILD_DEPENDS= devel/p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Devel-LexAlias>=0:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ p5-Devel-REPL>=0:${PORTSDIR}/devel/p5-Devel-REPL \
+ p5-Devel-StackTrace-WithLexicals>0:${PORTSDIR}/devel/p5-Devel-StackTrace-WithLexicals \
+ p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS= devel/p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-Devel-LexAlias>=0:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ p5-Devel-REPL>=0:${PORTSDIR}/devel/p5-Devel-REPL \
+ p5-Devel-StackTrace-WithLexicals>0:${PORTSDIR}/devel/p5-Devel-StackTrace-WithLexicals \
+ p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+
+USE_PERL= yes
+PERL_CONFIGURE= yes
+
+MAN3= Carp::REPL.3 Devel::REPL::Plugin::Carp::REPL.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Carp-REPL/distinfo b/devel/p5-Carp-REPL/distinfo
new file mode 100644
index 000000000000..8e0b9e9bf2d9
--- /dev/null
+++ b/devel/p5-Carp-REPL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Carp-REPL-0.15.tar.gz) = 036eba86df2576a56917a01f7f6830425bfd9c286755d611115cbe806a1639ee
+SIZE (Carp-REPL-0.15.tar.gz) = 23690
diff --git a/devel/p5-Carp-REPL/pkg-descr b/devel/p5-Carp-REPL/pkg-descr
new file mode 100644
index 000000000000..c70a8751bd0b
--- /dev/null
+++ b/devel/p5-Carp-REPL/pkg-descr
@@ -0,0 +1,3 @@
+Read-Eval-Print-Loop on die and/or warn
+
+WWW: http://search.cpan.org/dist/Carp-REPL/
diff --git a/devel/p5-Carp-REPL/pkg-plist b/devel/p5-Carp-REPL/pkg-plist
new file mode 100644
index 000000000000..0596ca7d5832
--- /dev/null
+++ b/devel/p5-Carp-REPL/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/REPL/.packlist
+%%SITE_PERL%%/Devel/REPL/Plugin/Carp/REPL.pm
+%%SITE_PERL%%/Carp/REPL.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/REPL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin/Carp
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin
+@dirrmtry %%SITE_PERL%%/Devel/REPL
+@dirrmtry %%SITE_PERL%%/Devel
+@dirrmtry %%SITE_PERL%%/Carp