aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Cdk
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:33:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:33:30 +0000
commit7e2d88220c43c2f9b9f148c67bcc9076b770fc7f (patch)
treec614c26e85fd7371a7c8ea0baf75417421aab144 /devel/p5-Cdk
parentd01082dac50f71caa3abf42f35e0bd967a3ae381 (diff)
downloadports-7e2d88220c43c2f9b9f148c67bcc9076b770fc7f.tar.gz
ports-7e2d88220c43c2f9b9f148c67bcc9076b770fc7f.zip
Notes
Diffstat (limited to 'devel/p5-Cdk')
-rw-r--r--devel/p5-Cdk/Makefile22
-rw-r--r--devel/p5-Cdk/distinfo1
-rw-r--r--devel/p5-Cdk/files/patch-aa14
-rw-r--r--devel/p5-Cdk/files/patch-ab97
-rw-r--r--devel/p5-Cdk/pkg-comment1
-rw-r--r--devel/p5-Cdk/pkg-descr3
-rw-r--r--devel/p5-Cdk/pkg-plist31
7 files changed, 169 insertions, 0 deletions
diff --git a/devel/p5-Cdk/Makefile b/devel/p5-Cdk/Makefile
new file mode 100644
index 000000000000..e24d96c5758c
--- /dev/null
+++ b/devel/p5-Cdk/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Cdk
+# Date created: May 27th 2001
+# Whom: Chia-liang Kao <clkao@clkao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cdk
+PORTVERSION= 4.9.6
+CATEGORIES= devel perl5
+MASTER_SITES= http://www.vexus.ca/release/
+PKGNAMEPREFIX= p5-
+DISTNAME= cdkperl
+
+MAINTAINER= clkao@clkao.org
+
+LIB_DEPENDS= cdk.1:${PORTSDIR}/devel/cdk
+
+WRKSRC= ${WRKDIR}/Cdk
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Cdk/distinfo b/devel/p5-Cdk/distinfo
new file mode 100644
index 000000000000..36f6ce7bb020
--- /dev/null
+++ b/devel/p5-Cdk/distinfo
@@ -0,0 +1 @@
+MD5 (cdkperl.tar.gz) = d6b33b1ac22f6153633f34f1d5394021
diff --git a/devel/p5-Cdk/files/patch-aa b/devel/p5-Cdk/files/patch-aa
new file mode 100644
index 000000000000..8e2eb4d9f938
--- /dev/null
+++ b/devel/p5-Cdk/files/patch-aa
@@ -0,0 +1,14 @@
+--- Makefile.PL.orig Fri Dec 11 03:50:16 1998
++++ Makefile.PL Sun May 27 05:23:05 2001
+@@ -16,9 +16,9 @@
+ WriteMakefile(
+ 'NAME' => 'Cdk',
+ 'VERSION' => '4.9.6',
+- 'LIBS' => ['-L/home/glover/local/lib -lcdk -lncurses'],
++ 'LIBS' => ['-L/usr/local/lib -lcdk -lncurses'],
+ 'DEFINE' => '-DHAVE_USLEEP -DHAVE_NCURSES -DHAVE_COLOR -DCDK_PERL_EXT',
+- 'INC' => '-I/usr/include/ncurses -I/home/glover/local/include/cdk',
++ 'INC' => '-I/usr/include -I/usr/local/include/cdk',
+ 'clean' => {FILES => 'Makefile.old'},
+ );
+
diff --git a/devel/p5-Cdk/files/patch-ab b/devel/p5-Cdk/files/patch-ab
new file mode 100644
index 000000000000..703fe2156e78
--- /dev/null
+++ b/devel/p5-Cdk/files/patch-ab
@@ -0,0 +1,97 @@
+--- Cdk.xs.orig Fri Dec 11 03:03:35 1998
++++ Cdk.xs Sun May 27 05:29:38 2001
+@@ -26,7 +26,7 @@
+ for (y=0; y <= subLen; y++) \
+ { \
+ SV *sv = *av_fetch(subArray,y,FALSE); \
+- (NEWARRAY)[x+(START)][y+(START)] = copyChar((char *)SvPV(sv,na)); \
++ (NEWARRAY)[x+(START)][y+(START)] = copyChar((char *)SvPV(sv,PL_na)); \
+ } \
+ } \
+ (ARRAYLEN)++; \
+@@ -87,7 +87,7 @@
+ for (x=0; x <= (LEN); x++) \
+ { \
+ SV *foo = *av_fetch(src, x, FALSE); \
+- (DEST)[x+(START)] = copyChar((char *)SvPV(foo,na)); \
++ (DEST)[x+(START)] = copyChar((char *)SvPV(foo,PL_na)); \
+ } \
+ (LEN)++; \
+ } while (0)
+@@ -107,11 +107,11 @@
+ SV *foo = *av_fetch(src, x, FALSE); \
+ if (lines == 0) \
+ { \
+- sprintf ((DEST), "%s", (char *)SvPV(foo,na)); \
++ sprintf ((DEST), "%s", (char *)SvPV(foo,PL_na)); \
+ } \
+ else \
+ { \
+- sprintf ((DEST), "%s\n%s", (DEST), (char *)SvPV(foo,na)); \
++ sprintf ((DEST), "%s\n%s", (DEST), (char *)SvPV(foo,PL_na)); \
+ } \
+ lines++; \
+ } \
+@@ -123,7 +123,7 @@
+ } \
+ else \
+ { \
+- sprintf ((DEST), "%s", (char *)SvPV(INPUT,na)); \
++ sprintf ((DEST), "%s", (char *)SvPV(INPUT,PL_na)); \
+ } \
+ } while (0)
+
+@@ -299,7 +299,7 @@
+ {
+ if (SvPOK(sv))
+ {
+- char *name = SvPV(sv,na);
++ char *name = SvPV(sv,PL_na);
+ chtype *fillerChtype;
+ chtype filler;
+ int j1, j2;
+@@ -608,7 +608,7 @@
+ {
+ if (SvPOK(sv))
+ {
+- char *name = SvPV(sv,na);
++ char *name = SvPV(sv,PL_na);
+ if (strEQ (name, "vENTRY"))
+ return vENTRY;
+ if (strEQ (name, "vMENTRY"))
+@@ -646,7 +646,7 @@
+ {
+ if (SvPOK(sv))
+ {
+- char *name = SvPV(sv,na);
++ char *name = SvPV(sv,PL_na);
+ if (strEQ (name, "CHAR"))
+ return vCHAR;
+ if (strEQ (name, "HCHAR"))
+@@ -697,7 +697,7 @@
+ {
+ if (SvPOK(sv))
+ {
+- char *name = SvPV(sv,na);
++ char *name = SvPV(sv,PL_na);
+ if (strEQ(name, "BOTTOM"))
+ return BOTTOM;
+ if (strEQ(name, "CENTER"))
+@@ -736,7 +736,7 @@
+ sv2CharPtr(inp)
+ SV *inp;
+ {
+- char *name = (char *)SvPV(inp,na);
++ char *name = (char *)SvPV(inp,PL_na);
+ return (name);
+ }
+
+@@ -6424,7 +6424,7 @@
+ CDKALPHALIST * object
+ PPCODE:
+ {
+- SV *sv = (SV *)&sv_undef;
++ SV *sv = (SV *)&PL_sv_undef;
+ chtype Keys[300];
+ int arrayLen;
+ char *value;
diff --git a/devel/p5-Cdk/pkg-comment b/devel/p5-Cdk/pkg-comment
new file mode 100644
index 000000000000..7a7c6062db5e
--- /dev/null
+++ b/devel/p5-Cdk/pkg-comment
@@ -0,0 +1 @@
+Perl5 module for Curses Development Kit
diff --git a/devel/p5-Cdk/pkg-descr b/devel/p5-Cdk/pkg-descr
new file mode 100644
index 000000000000..e0e8de42dbd2
--- /dev/null
+++ b/devel/p5-Cdk/pkg-descr
@@ -0,0 +1,3 @@
+Perl interface to Curses Development Kit.
+
+WWW: http://www.vexus.ca/CDK.html#Perl
diff --git a/devel/p5-Cdk/pkg-plist b/devel/p5-Cdk/pkg-plist
new file mode 100644
index 000000000000..2e05c50c08c6
--- /dev/null
+++ b/devel/p5-Cdk/pkg-plist
@@ -0,0 +1,31 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Alphalist.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Buttonbox.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Calendar.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Debug.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Diag.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Dialog.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Entry.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Fselect.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Graph.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Histogram.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Itemlist.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Marquee.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Matrix.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Menu.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Mentry.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Label.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Radio.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Scale.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Scroll.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Selection.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Slider.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Swindow.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Template.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk/Viewer.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cdk/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cdk/Cdk.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cdk/Cdk.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cdk/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Cdk
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Cdk