aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Container/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-07-05 12:14:03 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-07-05 12:14:03 +0000
commit9c5080165f1e32ac2269917c8f5655b63a0393c8 (patch)
treec3f7cd8e8c876b6f2d33d7d5443ea4c4162d81e3 /devel/p5-Class-Container/Makefile
parent34a9256d6580372bacbeb84489cae9ae29ee20c6 (diff)
Notes
Diffstat (limited to 'devel/p5-Class-Container/Makefile')
-rw-r--r--devel/p5-Class-Container/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/p5-Class-Container/Makefile b/devel/p5-Class-Container/Makefile
new file mode 100644
index 000000000000..df50217e6036
--- /dev/null
+++ b/devel/p5-Class-Container/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Class::Container
+# Date created: 5 July 2002
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Container
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dsh@vlink.ru
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Class::Container.3
+
+.include <bsd.port.mk>