aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Factory
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 09:38:47 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 09:38:47 +0000
commit9263aca63d4095926c80475a520c78dbc7a9b292 (patch)
tree33ab1811835aaf154a27f5be3c0c44c61b5224bf /devel/p5-Class-Factory
parent567ae38890475ce34d2eb69f37c0b04ba0abce5e (diff)
downloadports-9263aca63d4095926c80475a520c78dbc7a9b292.tar.gz
ports-9263aca63d4095926c80475a520c78dbc7a9b292.zip
Notes
Diffstat (limited to 'devel/p5-Class-Factory')
-rw-r--r--devel/p5-Class-Factory/Makefile22
-rw-r--r--devel/p5-Class-Factory/distinfo1
-rw-r--r--devel/p5-Class-Factory/pkg-comment1
-rw-r--r--devel/p5-Class-Factory/pkg-descr12
-rw-r--r--devel/p5-Class-Factory/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Class-Factory/Makefile b/devel/p5-Class-Factory/Makefile
new file mode 100644
index 000000000000..a49f952eb9e8
--- /dev/null
+++ b/devel/p5-Class-Factory/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Class-Accessor
+# Date created: 6 Mar 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Factory
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Factory.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Factory/distinfo b/devel/p5-Class-Factory/distinfo
new file mode 100644
index 000000000000..13428d627710
--- /dev/null
+++ b/devel/p5-Class-Factory/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Factory-0.03.tar.gz) = bb37d56f8d4b05498534968d2fa54f3b
diff --git a/devel/p5-Class-Factory/pkg-comment b/devel/p5-Class-Factory/pkg-comment
new file mode 100644
index 000000000000..a66b51dffc33
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-comment
@@ -0,0 +1 @@
+Base class for dynamic factory classes
diff --git a/devel/p5-Class-Factory/pkg-descr b/devel/p5-Class-Factory/pkg-descr
new file mode 100644
index 000000000000..415f04557534
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-descr
@@ -0,0 +1,12 @@
+This is a simple module that factory classes can use to generate new
+types of objects on the fly, providing a consistent interface to common
+groups of objects.
+
+Factory classes are used when you have different implementations for the
+same set of tasks but may not know in advance what implementations you
+will be using.
+
+WWW: http://search.cpan.org/search?dist=Class-Factory
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Class-Factory/pkg-plist b/devel/p5-Class-Factory/pkg-plist
new file mode 100644
index 000000000000..0e7d0a3dcde9
--- /dev/null
+++ b/devel/p5-Class-Factory/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Factory/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Class/Factory.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Factory
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true