aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Handle
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-02-12 13:38:56 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-02-12 13:38:56 +0000
commitf3a08e71c648ba509f09338b8f851088de0475d0 (patch)
tree1c61efa9c770ba5fa10a76f1b224b7a42f72985b /devel/p5-Class-Handle
parent3e34029c2ea0aaad41f948ba61f734598585c972 (diff)
downloadports-f3a08e71c648ba509f09338b8f851088de0475d0.tar.gz
ports-f3a08e71c648ba509f09338b8f851088de0475d0.zip
Notes
Diffstat (limited to 'devel/p5-Class-Handle')
-rw-r--r--devel/p5-Class-Handle/Makefile27
-rw-r--r--devel/p5-Class-Handle/distinfo2
-rw-r--r--devel/p5-Class-Handle/pkg-descr11
-rw-r--r--devel/p5-Class-Handle/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Class-Handle/Makefile b/devel/p5-Class-Handle/Makefile
new file mode 100644
index 000000000000..50a270ccae1d
--- /dev/null
+++ b/devel/p5-Class-Handle/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Class-Handle
+# Date created: 12 February 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Handle
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Create objects that are handles to classes
+
+RUN_DEPENDS= ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Handle.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Handle/distinfo b/devel/p5-Class-Handle/distinfo
new file mode 100644
index 000000000000..233320cd81db
--- /dev/null
+++ b/devel/p5-Class-Handle/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-Handle-1.03.tar.gz) = 490bf8ddb2095482e0a932d686383d55
+SIZE (Class-Handle-1.03.tar.gz) = 15894
diff --git a/devel/p5-Class-Handle/pkg-descr b/devel/p5-Class-Handle/pkg-descr
new file mode 100644
index 000000000000..febc4a6ddfc6
--- /dev/null
+++ b/devel/p5-Class-Handle/pkg-descr
@@ -0,0 +1,11 @@
+Class related functionality in Perl is broken up into a variety of
+different modules. Class::Handle attempts to provide a convenient
+object wrapper around the various different types of functions that can
+be performed on a class.
+
+Currently, Class::Handle provies what is effectively a combined API from
+UNIVERSAL, Class::ISA and Class::Inspector for obtaining information
+about a Class, and some additional task methods, such as load to common
+tasks relating to classes.
+
+WWW: http://search.cpan.org/dist/Class-Handle/
diff --git a/devel/p5-Class-Handle/pkg-plist b/devel/p5-Class-Handle/pkg-plist
new file mode 100644
index 000000000000..43de7d1e0b12
--- /dev/null
+++ b/devel/p5-Class-Handle/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Handle/.packlist
+%%SITE_PERL%%/Class/Handle.pm
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Handle
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true