aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-InsideOut/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:09:44 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 14:09:44 +0000
commit3705fac30af33c1cff970a41296e223fdb226bc0 (patch)
tree1626f4bbc23eff6de7f565225bf66298a68bc8da /devel/p5-Class-InsideOut/Makefile
parent2caa7eeda3ad95652413192122df809971461c48 (diff)
downloadports-3705fac30af33c1cff970a41296e223fdb226bc0.tar.gz
ports-3705fac30af33c1cff970a41296e223fdb226bc0.zip
Notes
Diffstat (limited to 'devel/p5-Class-InsideOut/Makefile')
-rw-r--r--devel/p5-Class-InsideOut/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/p5-Class-InsideOut/Makefile b/devel/p5-Class-InsideOut/Makefile
new file mode 100644
index 000000000000..2f6ef85a5790
--- /dev/null
+++ b/devel/p5-Class-InsideOut/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Class-InsideOut
+# Date created: 2006-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-InsideOut
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A safe, simple inside-out object construction kit
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::InsideOut::Manual::About.3 Class::InsideOut.3 \
+ Class::InsideOut::Manual::Advanced.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500701
+RUN_DEPENDS+= ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA
+.endif
+
+.if ${PERL_LEVEL} < 500702
+RUN_DEPENDS+= ${SITE_PERL}/Config.pm:${PORTSDIR}/devel/p5-Config \
+ ${SITE_PERL}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>