aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-STL-Containers
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-13 02:28:29 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-13 02:28:29 +0000
commitaf81c01a21116dc1c4d0204ffa901d1f2bd6d1ab (patch)
tree4185b10f717168ef09d433bbb9cf07a8107460ce /devel/p5-Class-STL-Containers
parentf2a2bcfef8f2e0289fc45b2bfa8325e356e52de6 (diff)
downloadports-af81c01a21116dc1c4d0204ffa901d1f2bd6d1ab.tar.gz
ports-af81c01a21116dc1c4d0204ffa901d1f2bd6d1ab.zip
Notes
Diffstat (limited to 'devel/p5-Class-STL-Containers')
-rw-r--r--devel/p5-Class-STL-Containers/Makefile26
-rw-r--r--devel/p5-Class-STL-Containers/distinfo3
-rw-r--r--devel/p5-Class-STL-Containers/pkg-descr8
-rw-r--r--devel/p5-Class-STL-Containers/pkg-plist20
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/p5-Class-STL-Containers/Makefile b/devel/p5-Class-STL-Containers/Makefile
new file mode 100644
index 000000000000..7d69d5e519a0
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Class-STL-Containers
+# Date created: 12 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-STL-Containers
+PORTVERSION= 0.26
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for STL-like object management
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500807
+IGNORE= requires at least Perl 5.8.7. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-STL-Containers/distinfo b/devel/p5-Class-STL-Containers/distinfo
new file mode 100644
index 000000000000..636ab789f57b
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-STL-Containers-0.26.tar.gz) = d24625f7cb3543cd699d04d2b8205002
+SHA256 (Class-STL-Containers-0.26.tar.gz) = 8993d408f68e834e663998b78540906c7c3d6b5a6c4ffbca84395f66ddee0259
+SIZE (Class-STL-Containers-0.26.tar.gz) = 64190
diff --git a/devel/p5-Class-STL-Containers/pkg-descr b/devel/p5-Class-STL-Containers/pkg-descr
new file mode 100644
index 000000000000..1f942a3e04b5
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/pkg-descr
@@ -0,0 +1,8 @@
+This package provides a framework for rapid Object Oriented Perl
+application development. It consists of a number of base classes that are
+similar to the C++/STL framework, plus a number of helper classes which
+provide the glue to transparently generate common functions, and will
+enable you to put your Perl application together very quickly.
+
+WWW: http://search.cpan.org/dist/Class-STL-Containers
+Author: m gaffiero <gaffie@users.sourceforge.net>
diff --git a/devel/p5-Class-STL-Containers/pkg-plist b/devel/p5-Class-STL-Containers/pkg-plist
new file mode 100644
index 000000000000..404fa7d943d3
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Class/STL/Algorithms.pm
+%%SITE_PERL%%/Class/STL/ClassMembers.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/Constructor.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/DataMember.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/Disable.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/FunctionMember.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/SingletonConstructor.pm
+%%SITE_PERL%%/Class/STL/Containers.pm
+%%SITE_PERL%%/Class/STL/Element.pm
+%%SITE_PERL%%/Class/STL/Iterators.pm
+%%SITE_PERL%%/Class/STL/Trace.pm
+%%SITE_PERL%%/Class/STL/Utilities.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL/Containers/.packlist
+%%SITE_PERL%%/stl.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL/Containers
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class/STL/ClassMembers
+@dirrmtry %%SITE_PERL%%/Class/STL
+@dirrmtry %%SITE_PERL%%/Class