aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Spiffy
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-20 11:20:47 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-20 11:20:47 +0000
commit431f1f52fbb462c9c4876bb6fcf2a08b72db5b64 (patch)
treecb34fcab9f9883873880ec0dae94e237f16664c7 /devel/p5-Class-Spiffy
parent98b3bd8d077c4acf0fda407d091773a19c080147 (diff)
downloadports-431f1f52fbb462c9c4876bb6fcf2a08b72db5b64.tar.gz
ports-431f1f52fbb462c9c4876bb6fcf2a08b72db5b64.zip
Notes
Diffstat (limited to 'devel/p5-Class-Spiffy')
-rw-r--r--devel/p5-Class-Spiffy/Makefile31
-rw-r--r--devel/p5-Class-Spiffy/distinfo3
-rw-r--r--devel/p5-Class-Spiffy/pkg-descr7
-rw-r--r--devel/p5-Class-Spiffy/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Class-Spiffy/Makefile b/devel/p5-Class-Spiffy/Makefile
new file mode 100644
index 000000000000..3ee937e60009
--- /dev/null
+++ b/devel/p5-Class-Spiffy/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Class-Spiffy
+# Date created: 20 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Spiffy
+PORTVERSION= 0.12
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Class::Spiffy - Spiffy Perl Interface Framework For You
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Spiffy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Spiffy/distinfo b/devel/p5-Class-Spiffy/distinfo
new file mode 100644
index 000000000000..00e8b72471f5
--- /dev/null
+++ b/devel/p5-Class-Spiffy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Spiffy-0.12.tar.gz) = aeac88ac8bc30cc6efada5a8e54bf60a
+SHA256 (Class-Spiffy-0.12.tar.gz) = cd539058bd138189500f8c2d47556306fc2eda552d51637b48029e0e0da81d0e
+SIZE (Class-Spiffy-0.12.tar.gz) = 24580
diff --git a/devel/p5-Class-Spiffy/pkg-descr b/devel/p5-Class-Spiffy/pkg-descr
new file mode 100644
index 000000000000..5da327233d8b
--- /dev/null
+++ b/devel/p5-Class-Spiffy/pkg-descr
@@ -0,0 +1,7 @@
+Class::Spiffy is a framework and methodology for doing object oriented
+(OO) programming in Perl. Class::Spiffy combines the best parts of
+Exporter.pm, base.pm, mixin.pm and SUPER.pm into one magic foundation
+class. It attempts to fix all the nits and warts of traditional Perl OO,
+in a clean, straightforward and (perhaps someday) standard way.
+
+WWW: http://search.cpan.org/dist/Class-Spiffy/
diff --git a/devel/p5-Class-Spiffy/pkg-plist b/devel/p5-Class-Spiffy/pkg-plist
new file mode 100644
index 000000000000..151691016a7f
--- /dev/null
+++ b/devel/p5-Class-Spiffy/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/Spiffy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Spiffy/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Spiffy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true