aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Std
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:14:55 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:14:55 +0000
commit9a7e733057bcd6b7409efb36e0dbc5b2cbf6146f (patch)
treef793cd4da0e2e4f057f316c190d6448651daf25a /devel/p5-Class-Std
parent8e7a2b625b6cbdb6fc04110cf03eaad465997f40 (diff)
downloadports-9a7e733057bcd6b7409efb36e0dbc5b2cbf6146f.tar.gz
ports-9a7e733057bcd6b7409efb36e0dbc5b2cbf6146f.zip
Notes
Diffstat (limited to 'devel/p5-Class-Std')
-rw-r--r--devel/p5-Class-Std/Makefile35
-rw-r--r--devel/p5-Class-Std/distinfo3
-rw-r--r--devel/p5-Class-Std/pkg-descr12
-rw-r--r--devel/p5-Class-Std/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Class-Std/Makefile b/devel/p5-Class-Std/Makefile
new file mode 100644
index 000000000000..fc21ba996535
--- /dev/null
+++ b/devel/p5-Class-Std/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Class-Std
+# Date created: 30 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Std
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Support for creating standard "inside-out" classes
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Class::Std.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Std/distinfo b/devel/p5-Class-Std/distinfo
new file mode 100644
index 000000000000..178b03c53cbf
--- /dev/null
+++ b/devel/p5-Class-Std/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Std-v0.0.8.tar.gz) = dc01fecfc8d5886e41d2e8bc2f29a7a2
+SHA256 (Class-Std-v0.0.8.tar.gz) = a828d5f07d9a92e4851be6629309d80c7c598a8756b01cd94fd1f40d683b8ef9
+SIZE (Class-Std-v0.0.8.tar.gz) = 31100
diff --git a/devel/p5-Class-Std/pkg-descr b/devel/p5-Class-Std/pkg-descr
new file mode 100644
index 000000000000..2f927156cc6a
--- /dev/null
+++ b/devel/p5-Class-Std/pkg-descr
@@ -0,0 +1,12 @@
+Most programmers who use Perl's object-oriented features construct their
+objects by blessing a hash. But, in doing so, they undermine the
+robustness of the OO approach. Hash-based objects are unencapsulated:
+their entries are open for the world to access and modify.
+
+Objects without effective encapsulation are vulnerable. Instead of
+politely respecting their public interface, some clever client coder
+inevitably will realize that it's marginally faster to interact directly
+with the underlying implementation, pulling out attribute values
+directly from the hash of an object.
+
+WWW: http://search.cpan.org/dist/Class-Std/
diff --git a/devel/p5-Class-Std/pkg-plist b/devel/p5-Class-Std/pkg-plist
new file mode 100644
index 000000000000..1b4458f109b0
--- /dev/null
+++ b/devel/p5-Class-Std/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/Std.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Std/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Std
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class