aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Throwable
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-11-02 15:25:28 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-11-02 15:25:28 +0000
commit8224044dc235d1d05ace3892ffcbc869040a3ab6 (patch)
tree5a89cedfad1ad0f98850dd692485f471d6c8eec2 /devel/p5-Class-Throwable
parent372d09d168879b7edb2be58b769a8130b055dfe4 (diff)
downloadports-8224044dc235d1d05ace3892ffcbc869040a3ab6.tar.gz
ports-8224044dc235d1d05ace3892ffcbc869040a3ab6.zip
Notes
Diffstat (limited to 'devel/p5-Class-Throwable')
-rw-r--r--devel/p5-Class-Throwable/Makefile31
-rw-r--r--devel/p5-Class-Throwable/distinfo2
-rw-r--r--devel/p5-Class-Throwable/pkg-descr12
-rw-r--r--devel/p5-Class-Throwable/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Class-Throwable/Makefile b/devel/p5-Class-Throwable/Makefile
new file mode 100644
index 000000000000..09d3f2a2b98b
--- /dev/null
+++ b/devel/p5-Class-Throwable/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Class::Throwable
+# Date created: 1 November 2005
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Throwable
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A minimal lightweight exception class
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Class::Throwable.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Throwable/distinfo b/devel/p5-Class-Throwable/distinfo
new file mode 100644
index 000000000000..ed4dcf1ddc21
--- /dev/null
+++ b/devel/p5-Class-Throwable/distinfo
@@ -0,0 +1,2 @@
+MD5 (Class-Throwable-0.10.tar.gz) = 888ea61abfd8d9b60c024a997de9dbbd
+SIZE (Class-Throwable-0.10.tar.gz) = 10971
diff --git a/devel/p5-Class-Throwable/pkg-descr b/devel/p5-Class-Throwable/pkg-descr
new file mode 100644
index 000000000000..c8f1aec8f88d
--- /dev/null
+++ b/devel/p5-Class-Throwable/pkg-descr
@@ -0,0 +1,12 @@
+This module implements a minimal lightweight exception object. It is meant
+to be a compromise between more basic solutions like Carp which can only
+print information and cannot handle exception objects, and more complex
+solutions like Exception::Class which can be used to define complex inline
+exceptions and has a number of module dependencies.
+
+WWW: http://search.cpan.org/dist/Class-Throwable/
+Author: Stevan Little <stevan@iinteractive.com>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-Class-Throwable/pkg-plist b/devel/p5-Class-Throwable/pkg-plist
new file mode 100644
index 000000000000..61005db9236d
--- /dev/null
+++ b/devel/p5-Class-Throwable/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/Throwable.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Throwable/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Throwable
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true