aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Clone-Fast/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-14 21:23:23 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-14 21:23:23 +0000
commit604b19987486db6e56959a15259f2f24c71c1c09 (patch)
treee5c7ff2c1f892ee7b7066739ed00cd3ebbfec314 /devel/p5-Clone-Fast/Makefile
parentaf29c7ba624fbd8872b4cfb816712b9513486e98 (diff)
Notes
Diffstat (limited to 'devel/p5-Clone-Fast/Makefile')
-rw-r--r--devel/p5-Clone-Fast/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-Clone-Fast/Makefile b/devel/p5-Clone-Fast/Makefile
new file mode 100644
index 000000000000..ff6d8ded0fbc
--- /dev/null
+++ b/devel/p5-Clone-Fast/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Clone-Fast
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Clone-Fast
+PORTVERSION= 0.90.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Clone
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Natively copying Perl data structures
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PERL_CONFIGURE= yes
+
+MAN3= Clone::Fast.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>