aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Commands-Guarded/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-11-19 14:00:39 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-11-19 14:00:39 +0000
commit94d1d78dd89008f0988666ae42c2232a0f8ce1d3 (patch)
treef8e38c45cca7235fa7dedc3a8c42bada7f51e4d4 /devel/p5-Commands-Guarded/Makefile
parentae1ec8f3dc1e8236595aeed5f87444fdebbc245a (diff)
Notes
Diffstat (limited to 'devel/p5-Commands-Guarded/Makefile')
-rw-r--r--devel/p5-Commands-Guarded/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-Commands-Guarded/Makefile b/devel/p5-Commands-Guarded/Makefile
new file mode 100644
index 000000000000..a479111585ff
--- /dev/null
+++ b/devel/p5-Commands-Guarded/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Commands-Guarded
+# Date created: 19 November 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Commands-Guarded
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TR/TREY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Deterministic guarded commands for Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Commands::Guarded.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or newer"
+.endif
+
+.include <bsd.port.post.mk>