aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Commands-Guarded
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-11-19 14:00:39 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-11-19 14:00:39 +0000
commit94d1d78dd89008f0988666ae42c2232a0f8ce1d3 (patch)
treef8e38c45cca7235fa7dedc3a8c42bada7f51e4d4 /devel/p5-Commands-Guarded
parentae1ec8f3dc1e8236595aeed5f87444fdebbc245a (diff)
downloadports-94d1d78dd89008f0988666ae42c2232a0f8ce1d3.tar.gz
ports-94d1d78dd89008f0988666ae42c2232a0f8ce1d3.zip
Notes
Diffstat (limited to 'devel/p5-Commands-Guarded')
-rw-r--r--devel/p5-Commands-Guarded/Makefile28
-rw-r--r--devel/p5-Commands-Guarded/distinfo2
-rw-r--r--devel/p5-Commands-Guarded/pkg-descr6
-rw-r--r--devel/p5-Commands-Guarded/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Commands-Guarded/Makefile b/devel/p5-Commands-Guarded/Makefile
new file mode 100644
index 000000000000..a479111585ff
--- /dev/null
+++ b/devel/p5-Commands-Guarded/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Commands-Guarded
+# Date created: 19 November 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Commands-Guarded
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TR/TREY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Deterministic guarded commands for Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Commands::Guarded.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or newer"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Commands-Guarded/distinfo b/devel/p5-Commands-Guarded/distinfo
new file mode 100644
index 000000000000..d0e669d9d74a
--- /dev/null
+++ b/devel/p5-Commands-Guarded/distinfo
@@ -0,0 +1,2 @@
+MD5 (Commands-Guarded-0.01.tar.gz) = f2a942da877f9322db879eea2220abfb
+SIZE (Commands-Guarded-0.01.tar.gz) = 12323
diff --git a/devel/p5-Commands-Guarded/pkg-descr b/devel/p5-Commands-Guarded/pkg-descr
new file mode 100644
index 000000000000..092e25394184
--- /dev/null
+++ b/devel/p5-Commands-Guarded/pkg-descr
@@ -0,0 +1,6 @@
+This module implements a deterministic, rectifying variant on Dijkstra's
+guarded commands. Each named step is passed two blocks: an "ensure"
+block that defines a test for a necessary and sufficient condition of
+the step, and a "using" block that will cause that condition to obtain.
+
+WWW: http://search.cpan.org/dist/Commands-Guarded
diff --git a/devel/p5-Commands-Guarded/pkg-plist b/devel/p5-Commands-Guarded/pkg-plist
new file mode 100644
index 000000000000..8c3f91fb3fb7
--- /dev/null
+++ b/devel/p5-Commands-Guarded/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Commands/Guarded.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Commands/Guarded/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Commands/Guarded 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Commands 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Commands 2>/dev/null || true