aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-CommitBit
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-30 11:31:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-30 11:31:47 +0000
commit216d4958c341ee2e2d307a841e11c9121ca56ab8 (patch)
tree38acfcd0acb3fdcdf5b90aee3e3a1fc6ef427544 /devel/p5-CommitBit
parent0cb0e7af3a8f0f14d19f787a2ddf2cb08bea9eb3 (diff)
downloadports-216d4958c341ee2e2d307a841e11c9121ca56ab8.tar.gz
ports-216d4958c341ee2e2d307a841e11c9121ca56ab8.zip
Notes
Diffstat (limited to 'devel/p5-CommitBit')
-rw-r--r--devel/p5-CommitBit/Makefile38
-rw-r--r--devel/p5-CommitBit/distinfo3
-rw-r--r--devel/p5-CommitBit/pkg-descr6
-rw-r--r--devel/p5-CommitBit/pkg-plist21
4 files changed, 68 insertions, 0 deletions
diff --git a/devel/p5-CommitBit/Makefile b/devel/p5-CommitBit/Makefile
new file mode 100644
index 000000000000..2e81e0e1aed4
--- /dev/null
+++ b/devel/p5-CommitBit/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-CommitBit
+# Date created: 2006-12-30
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CommitBit
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JE/JESSE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A project administration tool
+
+RUN_DEPENDS= ${SITE_PERL}/Module/CoreList.pm:${PORTSDIR}/devel/p5-Module-CoreList \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-Jifty>=0.60728:${PORTSDIR}/www/p5-Jifty \
+ p5-Text-Password-Pronounceable>=0:${PORTSDIR}/security/p5-Text-Password-Pronounceable
+
+PERL_CONFIGURE= yes
+
+MAN3= CommitBit.3 \
+ CommitBit::Action::ConfirmEmail.3 \
+ CommitBit::Action::Login.3 \
+ CommitBit::Action::Logout.3 \
+ CommitBit::Notification::ConfirmAddress.3 \
+ CommitBit::Notification::InviteToProject.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500803 # from p5-Jifty
+IGNORE= requires perl 5.8.3 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-CommitBit/distinfo b/devel/p5-CommitBit/distinfo
new file mode 100644
index 000000000000..1c3ce64983bd
--- /dev/null
+++ b/devel/p5-CommitBit/distinfo
@@ -0,0 +1,3 @@
+MD5 (CommitBit-0.02.tar.gz) = c22dab80f02f6713e3c62c74b5dd236c
+SHA256 (CommitBit-0.02.tar.gz) = fd7d36e98edd7e81ed72b0b3b7c287ad7e858213a794480d02bd5bd5c04dfc37
+SIZE (CommitBit-0.02.tar.gz) = 41386
diff --git a/devel/p5-CommitBit/pkg-descr b/devel/p5-CommitBit/pkg-descr
new file mode 100644
index 000000000000..fd0a2a847741
--- /dev/null
+++ b/devel/p5-CommitBit/pkg-descr
@@ -0,0 +1,6 @@
+CommitBit is a tool for managing commit access to software
+projects. It also provides for a "code.yourorganization.org"
+site with links to your wiki, mailing lists, bug tracking
+and so on.
+
+WWW: http://search.cpan.org/dist/CommitBit/
diff --git a/devel/p5-CommitBit/pkg-plist b/devel/p5-CommitBit/pkg-plist
new file mode 100644
index 000000000000..0068ac95f241
--- /dev/null
+++ b/devel/p5-CommitBit/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CommitBit/.packlist
+%%SITE_PERL%%/CommitBit.pm
+%%SITE_PERL%%/CommitBit/Test.pm
+%%SITE_PERL%%/CommitBit/CurrentUser.pm
+%%SITE_PERL%%/CommitBit/Record.pm
+%%SITE_PERL%%/CommitBit/Dispatcher.pm
+%%SITE_PERL%%/CommitBit/Action/ConfirmEmail.pm
+%%SITE_PERL%%/CommitBit/Action/Login.pm
+%%SITE_PERL%%/CommitBit/Action/Logout.pm
+%%SITE_PERL%%/CommitBit/Action/CreateProjectMember.pm
+%%SITE_PERL%%/CommitBit/Model/Repository.pm
+%%SITE_PERL%%/CommitBit/Model/User.pm
+%%SITE_PERL%%/CommitBit/Model/ProjectMember.pm
+%%SITE_PERL%%/CommitBit/Model/Project.pm
+%%SITE_PERL%%/CommitBit/Notification/InviteToProject.pm
+%%SITE_PERL%%/CommitBit/Notification/ConfirmAddress.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CommitBit
+@dirrmtry %%SITE_PERL%%/CommitBit/Notification
+@dirrmtry %%SITE_PERL%%/CommitBit/Model
+@dirrmtry %%SITE_PERL%%/CommitBit/Action
+@dirrmtry %%SITE_PERL%%/CommitBit