aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-IniFiles
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-03 18:15:40 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-03 18:15:40 +0000
commit49b80109c5e434af4b0a1042bb257953afd49a23 (patch)
tree9a58f085db4d57b67a67099254241175f0046722 /devel/p5-Config-IniFiles
parent738eda67e3143a5b7d93b8ddf15edb9a3370b00a (diff)
downloadports-49b80109c5e434af4b0a1042bb257953afd49a23.tar.gz
ports-49b80109c5e434af4b0a1042bb257953afd49a23.zip
Notes
Diffstat (limited to 'devel/p5-Config-IniFiles')
-rw-r--r--devel/p5-Config-IniFiles/Makefile25
-rw-r--r--devel/p5-Config-IniFiles/distinfo1
-rw-r--r--devel/p5-Config-IniFiles/pkg-comment1
-rw-r--r--devel/p5-Config-IniFiles/pkg-descr20
-rw-r--r--devel/p5-Config-IniFiles/pkg-plist3
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Config-IniFiles/Makefile b/devel/p5-Config-IniFiles/Makefile
new file mode 100644
index 000000000000..4a96da1d5830
--- /dev/null
+++ b/devel/p5-Config-IniFiles/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Config-IniFiles
+# Date created: October 21st 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-IniFiles
+PORTVERSION= 1.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jeremy@external.org
+
+USE_PERL5= YES
+
+MAN3= Config::IniFiles.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-IniFiles/distinfo b/devel/p5-Config-IniFiles/distinfo
new file mode 100644
index 000000000000..f8616d36011a
--- /dev/null
+++ b/devel/p5-Config-IniFiles/distinfo
@@ -0,0 +1 @@
+MD5 (Config-IniFiles-1.8.tar.gz) = 2f76f242fac3a6c8975c41bec8ce0b86
diff --git a/devel/p5-Config-IniFiles/pkg-comment b/devel/p5-Config-IniFiles/pkg-comment
new file mode 100644
index 000000000000..b52d9066dddd
--- /dev/null
+++ b/devel/p5-Config-IniFiles/pkg-comment
@@ -0,0 +1 @@
+Perl5 module for reading .ini-style configuration files
diff --git a/devel/p5-Config-IniFiles/pkg-descr b/devel/p5-Config-IniFiles/pkg-descr
new file mode 100644
index 000000000000..64ae3110ddd2
--- /dev/null
+++ b/devel/p5-Config-IniFiles/pkg-descr
@@ -0,0 +1,20 @@
+Config::IniFiles provides a way to have readable configuration files
+outside your Perl script. The configuration can be safely reloaded upon
+receipt of a signal. Configurations can be imported (inherited,
+stacked,...), sections can be grouped, and settings can be accessed from
+a tied hash.
+
+USAGE
+
+Get a new Config::IniFiles object with the *new* method:
+
+ $cfg = Config::IniFiles->new( -file => "/path/configfile.ini" );
+ $cfg = new Config::IniFiles -file => "/path/configfile.ini";
+
+Optional named parameters may be specified after the configuration file
+name. See the *new* in the METHODS section, below.
+
+INI files consist of a number of sections, each preceeded with the
+section name in square brackets. Parameters are specified in each section
+as Name=Value. Any spaces around the equals sign will be i gnored, and the
+value extends to the end of the line.
diff --git a/devel/p5-Config-IniFiles/pkg-plist b/devel/p5-Config-IniFiles/pkg-plist
new file mode 100644
index 000000000000..e9784a9d1be6
--- /dev/null
+++ b/devel/p5-Config-IniFiles/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Config/IniFiles.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/IniFiles/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/IniFiles