aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-Setting/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-07-01 15:59:27 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-07-01 15:59:27 +0000
commit727985a6e855684511c96be94a4ec0c2118b7586 (patch)
tree7a39b3509269b6f93f5ea2bc77d92d8bc73bdd6c /devel/p5-Config-Setting/Makefile
parent304bf86d9af8c2bc92d4f791c2a1bae4c4362fe5 (diff)
downloadports-727985a6e855684511c96be94a4ec0c2118b7586.tar.gz
ports-727985a6e855684511c96be94a4ec0c2118b7586.zip
Notes
Diffstat (limited to 'devel/p5-Config-Setting/Makefile')
-rw-r--r--devel/p5-Config-Setting/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Config-Setting/Makefile b/devel/p5-Config-Setting/Makefile
new file mode 100644
index 000000000000..3b4fd91c2087
--- /dev/null
+++ b/devel/p5-Config-Setting/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Config-Setting
+# Date created: 1 July 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Setting
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= http://www.myrddin.demon.co.uk/dist/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Config::Setting.3 \
+ Config::Setting::Fileprovider.3 \
+ Config::Setting::IniParser.3 \
+ Config::Setting::XMLParser.3
+
+.include <bsd.port.mk>