aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-Std
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:16:54 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-30 18:16:54 +0000
commitb1db8a0638f7e8eb6cdf00720de619950b3f5d30 (patch)
treea0ebc39da4fc76877c8e45e1820584992c3a10c8 /devel/p5-Config-Std
parent9a7e733057bcd6b7409efb36e0dbc5b2cbf6146f (diff)
downloadports-b1db8a0638f7e8eb6cdf00720de619950b3f5d30.tar.gz
ports-b1db8a0638f7e8eb6cdf00720de619950b3f5d30.zip
Notes
Diffstat (limited to 'devel/p5-Config-Std')
-rw-r--r--devel/p5-Config-Std/Makefile34
-rw-r--r--devel/p5-Config-Std/distinfo3
-rw-r--r--devel/p5-Config-Std/pkg-descr13
-rw-r--r--devel/p5-Config-Std/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-Config-Std/Makefile b/devel/p5-Config-Std/Makefile
new file mode 100644
index 000000000000..06db38153615
--- /dev/null
+++ b/devel/p5-Config-Std/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Config-Std
+# Date created: 30 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Std
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.4
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Load and save configuration files in a standard format
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Class/Std.pm:${PORTSDIR}/devel/p5-Class-Std \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Config::Std.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Config-Std/distinfo b/devel/p5-Config-Std/distinfo
new file mode 100644
index 000000000000..2059ec1b79b3
--- /dev/null
+++ b/devel/p5-Config-Std/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-Std-v0.0.4.tar.gz) = 0aac46d684bb89988a563a561c545a21
+SHA256 (Config-Std-v0.0.4.tar.gz) = 40b455d1971960514a0b87c58a4d1656207e03cd6d7a33dd3c068f97ad3ed5d5
+SIZE (Config-Std-v0.0.4.tar.gz) = 12140
diff --git a/devel/p5-Config-Std/pkg-descr b/devel/p5-Config-Std/pkg-descr
new file mode 100644
index 000000000000..cedf2a45b2e5
--- /dev/null
+++ b/devel/p5-Config-Std/pkg-descr
@@ -0,0 +1,13 @@
+This module implements yet another damn configuration-file system.
+
+The configuration language is deliberately simple and limited, and the
+module works hard to preserve as much information (section order,
+comments, etc.) as possible when a configuration file is updated.
+
+See Chapter 19 of "Perl Best Practices" (O'Reilly, 2005) for the
+rationale for this approach.
+
+The configuration language is a slight extension of the Windows INI
+format.
+
+WWW: http://search.cpan.org/dist/Config-Std/
diff --git a/devel/p5-Config-Std/pkg-plist b/devel/p5-Config-Std/pkg-plist
new file mode 100644
index 000000000000..7cc53e16ba36
--- /dev/null
+++ b/devel/p5-Config-Std/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Config/Std.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Std/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Std
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Class