aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Const-Fast
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 21:38:33 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-12 21:38:33 +0000
commitd0f0aee88e9cba9f964b128179f9179df15a5a93 (patch)
treef695eb8130db242fa47d01cf5b719126fe48b6ad /devel/p5-Const-Fast
parent461ea0f7f77c3a5e92a04bff53c23d3ca1fcc634 (diff)
downloadports-d0f0aee88e9cba9f964b128179f9179df15a5a93.tar.gz
ports-d0f0aee88e9cba9f964b128179f9179df15a5a93.zip
Notes
Diffstat (limited to 'devel/p5-Const-Fast')
-rw-r--r--devel/p5-Const-Fast/Makefile24
-rw-r--r--devel/p5-Const-Fast/distinfo2
-rw-r--r--devel/p5-Const-Fast/pkg-descr9
-rw-r--r--devel/p5-Const-Fast/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Const-Fast/Makefile b/devel/p5-Const-Fast/Makefile
new file mode 100644
index 000000000000..c1127b9ad086
--- /dev/null
+++ b/devel/p5-Const-Fast/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Const-Fast
+# Date created: 2010-12-12
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Const-Fast
+PORTVERSION= 0.006
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/L/LE/LEONT/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Facility for creating read-only scalars, arrays, and hashes
+
+RUN_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+
+PERL_CONFIGURE= YES
+
+MAN3= Const::Fast.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Const-Fast/distinfo b/devel/p5-Const-Fast/distinfo
new file mode 100644
index 000000000000..9a1126ae6095
--- /dev/null
+++ b/devel/p5-Const-Fast/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Const-Fast-0.006.tar.gz) = 611287d6df7e721225696332a0e23665aaf4074c0eee69634edb372a4069c176
+SIZE (Const-Fast-0.006.tar.gz) = 13864
diff --git a/devel/p5-Const-Fast/pkg-descr b/devel/p5-Const-Fast/pkg-descr
new file mode 100644
index 000000000000..59f30c50bec7
--- /dev/null
+++ b/devel/p5-Const-Fast/pkg-descr
@@ -0,0 +1,9 @@
+This module was written because I stumbled on some serious issues of Readonly
+that aren't easily fixable without breaking backwards compatibility in subtle
+ways. In particular Readonly's use of ties is a source of subtle bugs and bad
+performance. Instead, this module uses the builtin readonly feature of perl,
+making access to the variables just as fast as any normal variable without
+the weird side-effects of ties. Readonly can do the same for scalars when
+Readonly::XS is installed, but chooses not to do so in the most common case.
+
+WWW: http://search.cpan.org/dist/Const-Fast/
diff --git a/devel/p5-Const-Fast/pkg-plist b/devel/p5-Const-Fast/pkg-plist
new file mode 100644
index 000000000000..522a853799ea
--- /dev/null
+++ b/devel/p5-Const-Fast/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Const/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Const/Fast/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Const/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Const
+@dirrmtry %%SITE_PERL%%/Const