aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Context-Preserve
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-05-12 06:23:34 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-05-12 06:23:34 +0000
commitaf9daeabe0d639efc74bea86a99a4159d6e1a42a (patch)
tree5b0f8424a017a6aa20bf4aeb0af724127413b146 /devel/p5-Context-Preserve
parent2c3a3129701c8ac6b0f7c4921071847bc7997b96 (diff)
Notes
Diffstat (limited to 'devel/p5-Context-Preserve')
-rw-r--r--devel/p5-Context-Preserve/Makefile22
-rw-r--r--devel/p5-Context-Preserve/distinfo3
-rw-r--r--devel/p5-Context-Preserve/pkg-descr5
-rw-r--r--devel/p5-Context-Preserve/pkg-plist5
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-Context-Preserve/Makefile b/devel/p5-Context-Preserve/Makefile
new file mode 100644
index 000000000000..b56eb14d0d8d
--- /dev/null
+++ b/devel/p5-Context-Preserve/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Context-Preserve
+# Date created: 12 May 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Context-Preserve
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JR/JROCKWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Run code after a subroutine call, preserving the context the subroutine
+
+PERL_CONFIGURE= yes
+
+MAN3= Context::Preserve.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Context-Preserve/distinfo b/devel/p5-Context-Preserve/distinfo
new file mode 100644
index 000000000000..b1d229c0f34d
--- /dev/null
+++ b/devel/p5-Context-Preserve/distinfo
@@ -0,0 +1,3 @@
+MD5 (Context-Preserve-0.01.tar.gz) = e28c24d9e85d3f7de1c7b9a545ba991a
+SHA256 (Context-Preserve-0.01.tar.gz) = 867c0ee574d1cc90aff019b547a7b78ba42ef879eef480f4c4764aae288d5a3f
+SIZE (Context-Preserve-0.01.tar.gz) = 13158
diff --git a/devel/p5-Context-Preserve/pkg-descr b/devel/p5-Context-Preserve/pkg-descr
new file mode 100644
index 000000000000..d8f0c18d5ff1
--- /dev/null
+++ b/devel/p5-Context-Preserve/pkg-descr
@@ -0,0 +1,5 @@
+Context::Preserve - run code after a subroutine call, preserving the
+context the subroutine would have seen if it were the last statement in
+the caller.
+
+WWW: http://search.cpan.org/dist/Context-Preserve/
diff --git a/devel/p5-Context-Preserve/pkg-plist b/devel/p5-Context-Preserve/pkg-plist
new file mode 100644
index 000000000000..1beac5018b08
--- /dev/null
+++ b/devel/p5-Context-Preserve/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Context/Preserve/.packlist
+%%SITE_PERL%%/Context/Preserve.pm
+@dirrmtry %%SITE_PERL%%/Context
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Context/Preserve
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Context