aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2007-01-05 15:10:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2007-01-05 15:10:36 +0000
commit5e3d975da5a5a7f7eb900812bc6a6e865bf24b74 (patch)
tree9915fa977bc19363e3cbff088d3e72680b4236a4 /devel/p5-Coro
parentccfea083ca5461085249dccd564fb6ec1fcffa3f (diff)
downloadports-5e3d975da5a5a7f7eb900812bc6a6e865bf24b74.tar.gz
ports-5e3d975da5a5a7f7eb900812bc6a6e865bf24b74.zip
Notes
Diffstat (limited to 'devel/p5-Coro')
-rw-r--r--devel/p5-Coro/Makefile3
-rw-r--r--devel/p5-Coro/distinfo6
-rw-r--r--devel/p5-Coro/files/patch-Coro-Makefile.PL50
3 files changed, 39 insertions, 20 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index e6e0064dc148..84c84b135550 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= Coro
-PORTVERSION= 3.1.1
+PORTVERSION= 3.2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Coro
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-3.11
MAINTAINER= perl@FreeBSD.org
COMMENT= Coro - coroutine process abstraction for perl
diff --git a/devel/p5-Coro/distinfo b/devel/p5-Coro/distinfo
index da5fbfe981f6..0d8f3ac878af 100644
--- a/devel/p5-Coro/distinfo
+++ b/devel/p5-Coro/distinfo
@@ -1,3 +1,3 @@
-MD5 (Coro-3.11.tar.gz) = b5e2accd75fbb4aaa83e7216e92e6a3d
-SHA256 (Coro-3.11.tar.gz) = 1ad4f9aa856b7b8d9add923d1cb5baf14064d4754d999090f6d402c7e5b7cd9d
-SIZE (Coro-3.11.tar.gz) = 62084
+MD5 (Coro-3.2.tar.gz) = a9e355ca6f0d4e31c11cd12ad96c1e74
+SHA256 (Coro-3.2.tar.gz) = f9eb54052df10f49b2735a5b0061004fb4ec0d186d1ddf8e0b1470899395de2d
+SIZE (Coro-3.2.tar.gz) = 62516
diff --git a/devel/p5-Coro/files/patch-Coro-Makefile.PL b/devel/p5-Coro/files/patch-Coro-Makefile.PL
index 150e720a0835..0b5e04fd491f 100644
--- a/devel/p5-Coro/files/patch-Coro-Makefile.PL
+++ b/devel/p5-Coro/files/patch-Coro-Makefile.PL
@@ -1,40 +1,60 @@
---- Coro/Makefile.PL.orig Sat Dec 9 19:48:35 2006
-+++ Coro/Makefile.PL Sat Dec 9 19:51:08 2006
-@@ -72,9 +72,7 @@
+--- Coro/Makefile.PL.orig Fri Dec 22 05:06:26 2006
++++ Coro/Makefile.PL Fri Jan 5 15:12:19 2007
+@@ -20,9 +20,7 @@
+
+ EOF
+
+-if (prompt ("Skip further questions and use defaults (y/n)?", "y") =~ /[yY]/) {
+ $ENV{PERL_MM_USE_DEFAULT} = 1;
+-}
+
+
+ $DEFINE .= " -DHAVE_MMAP" if $Config{d_mmap} eq "define" && $Config{d_munmap} eq "define";
+@@ -88,9 +86,7 @@
retry:
-- my $r = prompt "Use which implementation,\n" .
-- "<s>etjmp/longjump, <u>context, <i>rix, <l>inux or <w>indows?",
-- $iface;
-+ my $r = 'u';
- $iface = lc $1 if $r =~ /(\S)/;
+-my $r = prompt "Use which implementation,\n" .
+- "<s>etjmp/longjump, <u>context, <i>rix, <l>inux or <w>indows?",
+- $iface;
++my $r = 'u';
+ $iface = lc $1 if $r =~ /(\S)/;
- if ($iface eq "u") {
-@@ -132,7 +130,7 @@
+ if ($iface eq "u") {
+@@ -145,7 +141,7 @@
EOF
--my $stacksize = prompt ("C stack size factor", "16384");
+-my $stacksize = prompt ("C stack size factor?", "16384");
+my $stacksize = 65536;
$DEFINE .= " -DSTACKSIZE=$stacksize";
print "using a stacksize of $stacksize * sizeof(long)\n";
-@@ -159,7 +157,7 @@
+@@ -172,7 +168,7 @@
EOF
--my $stackguard = prompt ("Number of guard pages (0 disables)", "4");
+-my $stackguard = prompt ("Number of guard pages (0 disables)?", "4");
+my $stackguard = 4;
$DEFINE .= " -DSTACKGUARD=$stackguard";
print <<EOF;
-@@ -177,7 +175,7 @@
+@@ -190,8 +186,7 @@
EOF
--my $valgrind = prompt ("Enable valgrind support (y/n)", "n");
+-my $valgrind = prompt ("Enable valgrind support (y/n)?",
+- -r "/usr/include/valgrind/valgrind.h" ? "y" : "n");
+my $valgrind = 'n';
$DEFINE .= " -DUSE_VALGRIND=1" if $valgrind =~ /[yY]/;
+
+@@ -208,7 +203,7 @@
+
+ EOF
+
+-my $use_internals = prompt ("Prefer perl functions over coro functions (y/n)?", "n");
++my $use_internals = 'n';
+ $DEFINE .= " -DPREFER_PERL_FUNCTIONS=1" if $use_internals =~ /[yY]/;
+
print <<EOF;