aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-10 14:27:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-10 14:27:14 +0000
commit96c89afc2861d6f1193a44ed5b7c1d80aeaaffb8 (patch)
tree7f0c539638a79c6daba2486cc14fb3df0acc4386 /devel/p5-Coro
parentb2b20d240f41869961362690737d52bc6078b326 (diff)
downloadports-96c89afc2861d6f1193a44ed5b7c1d80aeaaffb8.tar.gz
ports-96c89afc2861d6f1193a44ed5b7c1d80aeaaffb8.zip
Notes
Diffstat (limited to 'devel/p5-Coro')
-rw-r--r--devel/p5-Coro/Makefile4
-rw-r--r--devel/p5-Coro/distinfo4
-rw-r--r--devel/p5-Coro/files/patch-Coro:Makefile.PL10
-rw-r--r--devel/p5-Coro/files/patch-Coro:State.xs13
4 files changed, 25 insertions, 6 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index 36817fba981b..ab6c9720a341 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Coro
-PORTVERSION= 0.97
+PORTVERSION= 1.0a
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Coro
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
+WRKSRC= ${WRKDIR}/${DISTNAME:S/a$//}
+
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/p5-Coro/distinfo b/devel/p5-Coro/distinfo
index 8f2bb98bf21d..6dced3c7ecfa 100644
--- a/devel/p5-Coro/distinfo
+++ b/devel/p5-Coro/distinfo
@@ -1,2 +1,2 @@
-MD5 (Coro-0.97.tar.gz) = 936866e17e6153db80718cccb9cfcce0
-SIZE (Coro-0.97.tar.gz) = 53897
+MD5 (Coro-1.0a.tar.gz) = f453b72e943238c1be1ef713a22957e3
+SIZE (Coro-1.0a.tar.gz) = 53985
diff --git a/devel/p5-Coro/files/patch-Coro:Makefile.PL b/devel/p5-Coro/files/patch-Coro:Makefile.PL
index 16466230d2e2..f35ea3f00d68 100644
--- a/devel/p5-Coro/files/patch-Coro:Makefile.PL
+++ b/devel/p5-Coro/files/patch-Coro:Makefile.PL
@@ -1,8 +1,8 @@
$FreeBSD$
---- Coro/Makefile.PL.orig Tue Dec 16 11:11:52 2003
-+++ Coro/Makefile.PL Tue Dec 16 11:14:33 2003
-@@ -31,58 +31,15 @@ if ($^O =~ /win32/i or $^O =~ /cygwin/)
+--- Coro/Makefile.PL.orig Tue Aug 10 03:53:02 2004
++++ Coro/Makefile.PL Tue Aug 10 16:14:57 2004
+@@ -31,62 +31,15 @@
$iface = "s";
}
@@ -54,6 +54,10 @@ $FreeBSD$
- standard (does that surprise you?), so this workaround might be needed
- (it's fast), although s and u should also work now.
-
+-For most systems, the default chosen should be OK. If you experience
+-problems then you should experiment with this setting and/or turn off
+-optimizations (make OPTIMIZE=-O0).
+-
-EOF
-
retry:
diff --git a/devel/p5-Coro/files/patch-Coro:State.xs b/devel/p5-Coro/files/patch-Coro:State.xs
new file mode 100644
index 000000000000..130972c623f3
--- /dev/null
+++ b/devel/p5-Coro/files/patch-Coro:State.xs
@@ -0,0 +1,13 @@
+--- Coro/State.xs.orig Tue Aug 10 03:54:35 2004
++++ Coro/State.xs Tue Aug 10 16:22:54 2004
+@@ -57,6 +57,10 @@
+
+ #include "CoroAPI.h"
+
++#ifndef PERL_MAGIC_ext
++# define PERL_MAGIC_ext '~'
++#endif
++
+ #ifdef USE_ITHREADS
+ static perl_mutex coro_mutex;
+ # define LOCK do { MUTEX_LOCK (&coro_mutex); } while (0)