aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Cvs
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 03:39:40 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 03:39:40 +0000
commita8f77bec5a352f858acbf0959621ce9ba0de973a (patch)
tree822e89e2d28c43218f9b325c7fa26bf4ec19c35b /devel/p5-Cvs
parent1d45831e0772a8c2293759cc416e6645a9572c70 (diff)
downloadports-a8f77bec5a352f858acbf0959621ce9ba0de973a.tar.gz
ports-a8f77bec5a352f858acbf0959621ce9ba0de973a.zip
Notes
Diffstat (limited to 'devel/p5-Cvs')
-rw-r--r--devel/p5-Cvs/Makefile51
-rw-r--r--devel/p5-Cvs/distinfo3
-rw-r--r--devel/p5-Cvs/pkg-descr3
-rw-r--r--devel/p5-Cvs/pkg-plist36
4 files changed, 93 insertions, 0 deletions
diff --git a/devel/p5-Cvs/Makefile b/devel/p5-Cvs/Makefile
new file mode 100644
index 000000000000..fde1a5560689
--- /dev/null
+++ b/devel/p5-Cvs/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: devel/p5-Cvs
+# Date created: 28 June 2007
+# Whom: Philip Drapeau <pdrapeau@advanis.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cvs
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RS/RSOLIV
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Cvs - Object oriented interface to the CVS command
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+PERL_CONFIGURE= yes
+
+MAN3= Cvs.3 Cvs::Command::Base.3 Cvs::Command::Checkout.3 \
+ Cvs::Command::Commit.3 Cvs::Command::Diff.3 \
+ Cvs::Command::Export.3 Cvs::Command::Login.3 \
+ Cvs::Command::Logout.3 Cvs::Command::Rdiff.3 \
+ Cvs::Command::Release.3 Cvs::Command::Status.3 \
+ Cvs::Command::Tag.3 Cvs::Command::Update.3 \
+ Cvs::Cvsroot.3 Cvs::Result::Base.3 Cvs::Result::Checkout.3 \
+ Cvs::Result::Commit.3 Cvs::Result::DiffItem.3 \
+ Cvs::Result::DiffList.3 Cvs::Result::Export.3 \
+ Cvs::Result::Login.3 Cvs::Result::Logout.3 \
+ Cvs::Result::RdiffItem.3 Cvs::Result::RdiffList.3 \
+ Cvs::Result::Release.3 Cvs::Result::Rtag.3 \
+ Cvs::Result::StatusItem.3 Cvs::Result::StatusList.3 \
+ Cvs::Result::Tag.3 Cvs::Result::Update.3 \
+ Cvs::Command::Rtag.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Handle.pm:${PORTSDIR}/devel/p5-IO
+.endif
+
+.if ${PERL_LEVEL} >= 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Tty.pm:${PORTSDIR}/devel/p5-IO-Tty
+.endif
+
+RUN_DEPENDS+= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS+= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Cvs/distinfo b/devel/p5-Cvs/distinfo
new file mode 100644
index 000000000000..bb8408d2ad50
--- /dev/null
+++ b/devel/p5-Cvs/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cvs-0.07.tar.gz) = bdfc93e4b32d7fb66cd580e3d2395527
+SHA256 (Cvs-0.07.tar.gz) = 34c137138a03ba611f924a7dbf52d0fb6320c8bf366dc2b85ae177d11d00b3f1
+SIZE (Cvs-0.07.tar.gz) = 24609
diff --git a/devel/p5-Cvs/pkg-descr b/devel/p5-Cvs/pkg-descr
new file mode 100644
index 000000000000..47c298aa1de4
--- /dev/null
+++ b/devel/p5-Cvs/pkg-descr
@@ -0,0 +1,3 @@
+Cvs Object oriented interface to the CVS command
+
+WWW: http://search.cpan.org/~rsoliv/Cvs-0.07/lib/Cvs.pm
diff --git a/devel/p5-Cvs/pkg-plist b/devel/p5-Cvs/pkg-plist
new file mode 100644
index 000000000000..ea1d06650f1f
--- /dev/null
+++ b/devel/p5-Cvs/pkg-plist
@@ -0,0 +1,36 @@
+%%SITE_PERL%%/Cvs.pm
+%%SITE_PERL%%/Cvs/Cvsroot.pm
+%%SITE_PERL%%/Cvs/Command/Checkout.pm
+%%SITE_PERL%%/Cvs/Command/Tag.pm
+%%SITE_PERL%%/Cvs/Command/Rdiff.pm
+%%SITE_PERL%%/Cvs/Command/Release.pm
+%%SITE_PERL%%/Cvs/Command/Login.pm
+%%SITE_PERL%%/Cvs/Command/Base.pm
+%%SITE_PERL%%/Cvs/Command/Export.pm
+%%SITE_PERL%%/Cvs/Command/Logout.pm
+%%SITE_PERL%%/Cvs/Command/Update.pm
+%%SITE_PERL%%/Cvs/Command/Rtag.pm
+%%SITE_PERL%%/Cvs/Command/Commit.pm
+%%SITE_PERL%%/Cvs/Command/Status.pm
+%%SITE_PERL%%/Cvs/Command/Diff.pm
+%%SITE_PERL%%/Cvs/Result/Release.pm
+%%SITE_PERL%%/Cvs/Result/RdiffItem.pm
+%%SITE_PERL%%/Cvs/Result/DiffList.pm
+%%SITE_PERL%%/Cvs/Result/StatusItem.pm
+%%SITE_PERL%%/Cvs/Result/RdiffList.pm
+%%SITE_PERL%%/Cvs/Result/Rtag.pm
+%%SITE_PERL%%/Cvs/Result/Commit.pm
+%%SITE_PERL%%/Cvs/Result/Base.pm
+%%SITE_PERL%%/Cvs/Result/Update.pm
+%%SITE_PERL%%/Cvs/Result/DiffItem.pm
+%%SITE_PERL%%/Cvs/Result/Login.pm
+%%SITE_PERL%%/Cvs/Result/Tag.pm
+%%SITE_PERL%%/Cvs/Result/Checkout.pm
+%%SITE_PERL%%/Cvs/Result/Export.pm
+%%SITE_PERL%%/Cvs/Result/Logout.pm
+%%SITE_PERL%%/Cvs/Result/StatusList.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cvs/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cvs
+@dirrm %%SITE_PERL%%/Cvs/Command
+@dirrm %%SITE_PERL%%/Cvs/Result
+@dirrm %%SITE_PERL%%/Cvs