aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Clone/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-04 18:58:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-04 18:58:31 +0000
commitf3b49c22f6508ef67cb22621f45a6663ca2837b9 (patch)
tree1d65da4a44a2b118e031a42845accbbea764b595 /devel/p5-Data-Clone/Makefile
parenteda8fde982f74011a8021422b17c2edea10adfaa (diff)
downloadports-f3b49c22f6508ef67cb22621f45a6663ca2837b9.tar.gz
ports-f3b49c22f6508ef67cb22621f45a6663ca2837b9.zip
Notes
Diffstat (limited to 'devel/p5-Data-Clone/Makefile')
-rw-r--r--devel/p5-Data-Clone/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Data-Clone/Makefile b/devel/p5-Data-Clone/Makefile
new file mode 100644
index 000000000000..d1ad68ce7974
--- /dev/null
+++ b/devel/p5-Data-Clone/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Data-Clone
+# Date created: 2011-10-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Clone
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Polymorphic data cloning
+
+TEST_DEPENDS= p5-Test-Requires>=0.03:${PORTSDIR}/devel/p5-Test-Requires
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Clone.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+RUN_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+RUN_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+.include <bsd.port.post.mk>