aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Dump-Streamer
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-03-23 15:06:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-03-23 15:06:01 +0000
commitf575c6f17ab4e94bb97fb710c4bbcc7c7d47f58f (patch)
treeca08975067067671b4d8aceedaf0871fd9c1d742 /devel/p5-Data-Dump-Streamer
parent9328b68b1d74d9c7cd60523b205416c7b84a30a0 (diff)
downloadports-f575c6f17ab4e94bb97fb710c4bbcc7c7d47f58f.tar.gz
ports-f575c6f17ab4e94bb97fb710c4bbcc7c7d47f58f.zip
Notes
Diffstat (limited to 'devel/p5-Data-Dump-Streamer')
-rw-r--r--devel/p5-Data-Dump-Streamer/Makefile35
-rw-r--r--devel/p5-Data-Dump-Streamer/distinfo2
-rw-r--r--devel/p5-Data-Dump-Streamer/pkg-descr12
-rw-r--r--devel/p5-Data-Dump-Streamer/pkg-plist12
4 files changed, 61 insertions, 0 deletions
diff --git a/devel/p5-Data-Dump-Streamer/Makefile b/devel/p5-Data-Dump-Streamer/Makefile
new file mode 100644
index 000000000000..2c49abf1a3cf
--- /dev/null
+++ b/devel/p5-Data-Dump-Streamer/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Data-Dump-Streamer
+# Date created: 23 March 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Dump-Streamer
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Stream a highly accurate breadth first data dump in perl code form to a var or file
+
+BUILD_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Dump::Streamer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+.endif
+.if ${PERL_LEVEL} < 500600
+IGNORE="Need at least perl 5.6 to build"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Dump-Streamer/distinfo b/devel/p5-Data-Dump-Streamer/distinfo
new file mode 100644
index 000000000000..f320438912c1
--- /dev/null
+++ b/devel/p5-Data-Dump-Streamer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Dump-Streamer-1.06.tar.gz) = 8fa94ec33d99f798ccb3bf9875b1550c
+SIZE (Data-Dump-Streamer-1.06.tar.gz) = 51507
diff --git a/devel/p5-Data-Dump-Streamer/pkg-descr b/devel/p5-Data-Dump-Streamer/pkg-descr
new file mode 100644
index 000000000000..515090969838
--- /dev/null
+++ b/devel/p5-Data-Dump-Streamer/pkg-descr
@@ -0,0 +1,12 @@
+Converts a data structure into a sequence of perl statements sufficient for
+recreating the original via eval. This module is very similar in concept to
+Data::Dumper and Data::Dump, with the major differences being that this module
+is designed to output to a stream instead of constructing its output in memory,
+and that the traversal over the data structure is effectively breadth first
+versus the depth first traversal done by the others.
+
+In fact the data structure is scanned twice, first in breadth first mode to
+perform structural analysis, and then in depth first mode to actually produce
+the output, but obeying the depth relationships of the first pass.
+
+WWW: http://search.cpan.org/dist/Data-Dump-Streamer/
diff --git a/devel/p5-Data-Dump-Streamer/pkg-plist b/devel/p5-Data-Dump-Streamer/pkg-plist
new file mode 100644
index 000000000000..7450d29afd4a
--- /dev/null
+++ b/devel/p5-Data-Dump-Streamer/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Dump/Streamer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Dump/Streamer/_/Printers.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dump/Streamer/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dump/Streamer/Streamer.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dump/Streamer/Streamer.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dump/Streamer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dump 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Data/Dump/Streamer/_
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Data/Dump/Streamer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Data/Dump 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Data 2>/dev/null || true