aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-DumpXML
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-02-08 07:54:28 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-02-08 07:54:28 +0000
commit2ee794b501f861e65def8226845a5e92706fac7f (patch)
treea94c85ee0a63f8729e51af1d34eb7accfb7668c3 /devel/p5-Data-DumpXML
parent7ce368b71b600f509ba8accf5c0cef8c85cf717a (diff)
downloadports-2ee794b501f861e65def8226845a5e92706fac7f.tar.gz
ports-2ee794b501f861e65def8226845a5e92706fac7f.zip
Notes
Diffstat (limited to 'devel/p5-Data-DumpXML')
-rw-r--r--devel/p5-Data-DumpXML/Makefile28
-rw-r--r--devel/p5-Data-DumpXML/distinfo1
-rw-r--r--devel/p5-Data-DumpXML/pkg-comment1
-rw-r--r--devel/p5-Data-DumpXML/pkg-descr8
-rw-r--r--devel/p5-Data-DumpXML/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Data-DumpXML/Makefile b/devel/p5-Data-DumpXML/Makefile
new file mode 100644
index 000000000000..6a0ba06ed317
--- /dev/null
+++ b/devel/p5-Data-DumpXML/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Data::DumpXML
+# Date created: 31 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-DumpXML
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Array/RefElem.pm:${PORTSDIR}/misc/p5-Array-RefElem \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Data::DumpXML.3 Data::DumpXML::Parser.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-DumpXML/distinfo b/devel/p5-Data-DumpXML/distinfo
new file mode 100644
index 000000000000..d2050ea1614a
--- /dev/null
+++ b/devel/p5-Data-DumpXML/distinfo
@@ -0,0 +1 @@
+MD5 (Data-DumpXML-1.03.tar.gz) = 80d665cb05288da1e13de5a84f51dde7
diff --git a/devel/p5-Data-DumpXML/pkg-comment b/devel/p5-Data-DumpXML/pkg-comment
new file mode 100644
index 000000000000..8fca733ef37b
--- /dev/null
+++ b/devel/p5-Data-DumpXML/pkg-comment
@@ -0,0 +1 @@
+Dump arbitrary data structures as XML
diff --git a/devel/p5-Data-DumpXML/pkg-descr b/devel/p5-Data-DumpXML/pkg-descr
new file mode 100644
index 000000000000..302626a4755a
--- /dev/null
+++ b/devel/p5-Data-DumpXML/pkg-descr
@@ -0,0 +1,8 @@
+This module provide a single function called dump_xml() that takes
+a list of perl values as argument and produce a string as result.
+The string returned is an XML document that represents any perl
+data structures passed in. Reference loops are handled correctly.
+
+WWW: http://search.cpan.org/search?dist=Data-DumpXML
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/devel/p5-Data-DumpXML/pkg-plist b/devel/p5-Data-DumpXML/pkg-plist
new file mode 100644
index 000000000000..d0f9bea56a71
--- /dev/null
+++ b/devel/p5-Data-DumpXML/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/Data/DumpXML.pm
+lib/perl5/site_perl/%%PERL_VER%%/Data/DumpXML/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/DumpXML/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/DumpXML
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Data/DumpXML
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Data 2>/dev/null || true