aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Dumper-Simple
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-12 13:00:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-12 13:00:19 +0000
commit75b09fa110d521f3285bfcaa7bef549bc0b447c6 (patch)
treeacb4d24686efd6c9054c730c6c1e92315faee16a /devel/p5-Data-Dumper-Simple
parent3e9ac88a241d375bc091cb4c433814244d5d4d1f (diff)
downloadports-75b09fa110d521f3285bfcaa7bef549bc0b447c6.tar.gz
ports-75b09fa110d521f3285bfcaa7bef549bc0b447c6.zip
Notes
Diffstat (limited to 'devel/p5-Data-Dumper-Simple')
-rw-r--r--devel/p5-Data-Dumper-Simple/Makefile32
-rw-r--r--devel/p5-Data-Dumper-Simple/distinfo2
-rw-r--r--devel/p5-Data-Dumper-Simple/pkg-descr17
-rw-r--r--devel/p5-Data-Dumper-Simple/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-Data-Dumper-Simple/Makefile b/devel/p5-Data-Dumper-Simple/Makefile
new file mode 100644
index 000000000000..d6b73200003d
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Data-Dumper-Simple
+# Date created: Sep 9 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Dumper-Simple
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Easily dump variables with names
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Dumper::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+BUILD_DEPENDS+= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE="Need at least perl 5.6.1 to build"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Dumper-Simple/distinfo b/devel/p5-Data-Dumper-Simple/distinfo
new file mode 100644
index 000000000000..8b9a3f915c5e
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Dumper-Simple-0.06.tar.gz) = cb2ab608bdbe289ad6db4baf4fa84ae7
+SIZE (Data-Dumper-Simple-0.06.tar.gz) = 6356
diff --git a/devel/p5-Data-Dumper-Simple/pkg-descr b/devel/p5-Data-Dumper-Simple/pkg-descr
new file mode 100644
index 000000000000..9aeb944ca20d
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/pkg-descr
@@ -0,0 +1,17 @@
+This module allow the user to dump variables in a Data::Dumper format.
+
+Unlike the default behavior of Data::Dumper, the variables are named
+(instead of $VAR1, $VAR2, etc.) Data::Dumper provides an extended
+interface that allows the programmer to name the variables, but this
+interface requires a lot of typing and is prone to tyops (sic). This
+module fixes that.
+
+Data::Dumper::Simple is actually a source filter that replaces all
+instances of Dumper($some, @args) in your code with a call to
+Data::Dumper->Dump(). You can use the one function provided to make
+dumping variables for debugging a trivial task.
+
+Note that this is primarily a debugging tool. Data::Dumper offers a
+bit more than that, so don't expect this module to be more than it is.
+
+WWW: http://search.cpan.org/dist/Data-Dumper-Simple/
diff --git a/devel/p5-Data-Dumper-Simple/pkg-plist b/devel/p5-Data-Dumper-Simple/pkg-plist
new file mode 100644
index 000000000000..d4d87156d2bd
--- /dev/null
+++ b/devel/p5-Data-Dumper-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Data/Dumper/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true