aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-HashArray/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-08-27 17:05:17 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-08-27 17:05:17 +0000
commitad6b1d184a3343170f90a09214fa0e10f2427e8d (patch)
treeba56556e462fd980894d53eb66412799e0be2370 /devel/p5-Data-HashArray/Makefile
parent685d41588ecc2b62cffaa7435a1629b67d92ac8c (diff)
Data::HashArray is an array of hashes or hash-based objects. This
class has some magical properties that make it easier to deal with multiplicity. WWW: http://search.cpan.org/dist/Data-HashArray/
Notes
Notes: svn path=/head/; revision=240416
Diffstat (limited to 'devel/p5-Data-HashArray/Makefile')
-rw-r--r--devel/p5-Data-HashArray/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/p5-Data-HashArray/Makefile b/devel/p5-Data-HashArray/Makefile
new file mode 100644
index 000000000000..31bba7fb1717
--- /dev/null
+++ b/devel/p5-Data-HashArray/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Data::HashArray
+# Date created: 2009-08-27
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-HashArray
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Array class of hashes with properties via overloading and AUTOLOAD
+
+BUILD_DEPENDS= p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::HashArray.3
+
+.include <bsd.port.mk>