aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-HashArray
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-08-27 17:05:17 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-08-27 17:05:17 +0000
commitad6b1d184a3343170f90a09214fa0e10f2427e8d (patch)
treeba56556e462fd980894d53eb66412799e0be2370 /devel/p5-Data-HashArray
parent685d41588ecc2b62cffaa7435a1629b67d92ac8c (diff)
downloadports-ad6b1d184a3343170f90a09214fa0e10f2427e8d.tar.gz
ports-ad6b1d184a3343170f90a09214fa0e10f2427e8d.zip
Notes
Diffstat (limited to 'devel/p5-Data-HashArray')
-rw-r--r--devel/p5-Data-HashArray/Makefile24
-rw-r--r--devel/p5-Data-HashArray/distinfo3
-rw-r--r--devel/p5-Data-HashArray/pkg-descr5
-rw-r--r--devel/p5-Data-HashArray/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Data-HashArray/Makefile b/devel/p5-Data-HashArray/Makefile
new file mode 100644
index 000000000000..31bba7fb1717
--- /dev/null
+++ b/devel/p5-Data-HashArray/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Data::HashArray
+# Date created: 2009-08-27
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-HashArray
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Array class of hashes with properties via overloading and AUTOLOAD
+
+BUILD_DEPENDS= p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::HashArray.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-HashArray/distinfo b/devel/p5-Data-HashArray/distinfo
new file mode 100644
index 000000000000..e25522952013
--- /dev/null
+++ b/devel/p5-Data-HashArray/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-HashArray-1.0.tar.gz) = 56b29c7834e68cec48c0c0bb7e101bd5
+SHA256 (Data-HashArray-1.0.tar.gz) = 51855bae8cc0c423216524e27e85a82afe8c983db90cbf7da1edf22f0a1ff8fe
+SIZE (Data-HashArray-1.0.tar.gz) = 6977
diff --git a/devel/p5-Data-HashArray/pkg-descr b/devel/p5-Data-HashArray/pkg-descr
new file mode 100644
index 000000000000..b5604733470a
--- /dev/null
+++ b/devel/p5-Data-HashArray/pkg-descr
@@ -0,0 +1,5 @@
+Data::HashArray is an array of hashes or hash-based objects. This
+class has some magical properties that make it easier to deal with
+multiplicity.
+
+WWW: http://search.cpan.org/dist/Data-HashArray/
diff --git a/devel/p5-Data-HashArray/pkg-plist b/devel/p5-Data-HashArray/pkg-plist
new file mode 100644
index 000000000000..6bacfe740206
--- /dev/null
+++ b/devel/p5-Data-HashArray/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/HashArray.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/HashArray/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/HashArray
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data