aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Hierarchy
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 17:00:39 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 17:00:39 +0000
commita6a150db52e8a23a356a864e8c3d1162c4840082 (patch)
tree6e46a8992430347c0a52525446af9739dbd56137 /devel/p5-Data-Hierarchy
parentb5cc6ddb0bbd84dbcafb1986039c5505ee721bcb (diff)
downloadports-a6a150db52e8a23a356a864e8c3d1162c4840082.tar.gz
ports-a6a150db52e8a23a356a864e8c3d1162c4840082.zip
Notes
Diffstat (limited to 'devel/p5-Data-Hierarchy')
-rw-r--r--devel/p5-Data-Hierarchy/Makefile25
-rw-r--r--devel/p5-Data-Hierarchy/distinfo1
-rw-r--r--devel/p5-Data-Hierarchy/pkg-descr2
-rw-r--r--devel/p5-Data-Hierarchy/pkg-plist4
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-Data-Hierarchy/Makefile b/devel/p5-Data-Hierarchy/Makefile
new file mode 100644
index 000000000000..536abed4787d
--- /dev/null
+++ b/devel/p5-Data-Hierarchy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Data-Hierarchy
+# Date created: Mar 15 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Hierarchy
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Handle data in a hierarchical structure
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Hierarchy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Hierarchy/distinfo b/devel/p5-Data-Hierarchy/distinfo
new file mode 100644
index 000000000000..bc2ce0c93305
--- /dev/null
+++ b/devel/p5-Data-Hierarchy/distinfo
@@ -0,0 +1 @@
+MD5 (Data-Hierarchy-0.15.tar.gz) = f0a2b4e9d60c48783e105a18e250815a
diff --git a/devel/p5-Data-Hierarchy/pkg-descr b/devel/p5-Data-Hierarchy/pkg-descr
new file mode 100644
index 000000000000..ebca8616b693
--- /dev/null
+++ b/devel/p5-Data-Hierarchy/pkg-descr
@@ -0,0 +1,2 @@
+Data::Hierarchy provides a simple interface for manipulating inheritable
+data attached to a hierarchical environment (like filesystem).
diff --git a/devel/p5-Data-Hierarchy/pkg-plist b/devel/p5-Data-Hierarchy/pkg-plist
new file mode 100644
index 000000000000..9ace0d111141
--- /dev/null
+++ b/devel/p5-Data-Hierarchy/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Data/Hierarchy.pm
+@dirrm %%SITE_PERL%%/Data
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Hierarchy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true