aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-ObjectDriver
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-02-25 14:38:13 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-02-25 14:38:13 +0000
commit133586c9d6aef7c816cfd42d164f80b9b2d45b3d (patch)
tree5a63bb9189a63b5fdf73e5ac76a9937737470a9b /devel/p5-Data-ObjectDriver
parent0cb0cc9d1d5aa7cad0d9ec90ebb477a69bbd52ef (diff)
Notes
Diffstat (limited to 'devel/p5-Data-ObjectDriver')
-rw-r--r--devel/p5-Data-ObjectDriver/Makefile37
-rw-r--r--devel/p5-Data-ObjectDriver/distinfo3
-rw-r--r--devel/p5-Data-ObjectDriver/pkg-descr16
-rw-r--r--devel/p5-Data-ObjectDriver/pkg-plist28
4 files changed, 84 insertions, 0 deletions
diff --git a/devel/p5-Data-ObjectDriver/Makefile b/devel/p5-Data-ObjectDriver/Makefile
new file mode 100644
index 000000000000..3f0a6a5dcb54
--- /dev/null
+++ b/devel/p5-Data-ObjectDriver/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Data-ObjectDriver
+# Date created: 2007-02-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-ObjectDriver
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple, transparent data interface, with caching
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger \
+ ${SITE_PERL}/Text/SimpleTable.pm:${PORTSDIR}/textproc/p5-Text-SimpleTable
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::ObjectDriver.3 Data::ObjectDriver::BaseObject.3 \
+ Data::ObjectDriver::Driver::DBD::SQLite.3 \
+ Data::ObjectDriver::Profiler.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-ObjectDriver/distinfo b/devel/p5-Data-ObjectDriver/distinfo
new file mode 100644
index 000000000000..34a6a55877ff
--- /dev/null
+++ b/devel/p5-Data-ObjectDriver/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-ObjectDriver-0.03.tar.gz) = 8845a4c669790de2d66521f5a83847b9
+SHA256 (Data-ObjectDriver-0.03.tar.gz) = 31029e1573596705f078225611502b01b4d646245298c7e1bafdfb22b0ee7e5e
+SIZE (Data-ObjectDriver-0.03.tar.gz) = 51733
diff --git a/devel/p5-Data-ObjectDriver/pkg-descr b/devel/p5-Data-ObjectDriver/pkg-descr
new file mode 100644
index 000000000000..7b82e6464009
--- /dev/null
+++ b/devel/p5-Data-ObjectDriver/pkg-descr
@@ -0,0 +1,16 @@
+Data::ObjectDriver is an object relational mapper, meaning that it
+maps object-oriented design concepts onto a relational database.
+
+It's inspired by, and descended from, the MT::ObjectDriver classes in
+Six Apart's Movable Type and TypePad weblogging products. But it adds
+in caching and partitioning layers, allowing you to spread data across
+multiple physical databases, without your application code needing to
+know where the data is stored.
+
+It's currently considered ALPHA code. The API is largely fixed, but
+may seen some small changes in the future. For what it's worth, the
+likeliest area for changes are in the syntax for the search method,
+and would most likely not break much in the way of backwards
+compatibility.
+
+WWW: http://search.cpan.org/dist/Data-ObjectDriver/
diff --git a/devel/p5-Data-ObjectDriver/pkg-plist b/devel/p5-Data-ObjectDriver/pkg-plist
new file mode 100644
index 000000000000..75a053fb2a6c
--- /dev/null
+++ b/devel/p5-Data-ObjectDriver/pkg-plist
@@ -0,0 +1,28 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ObjectDriver/.packlist
+%%SITE_PERL%%/Data/ObjectDriver.pm
+%%SITE_PERL%%/Data/ObjectDriver/BaseObject.pm
+%%SITE_PERL%%/Data/ObjectDriver/BaseView.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/._SimplePartition.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/BaseCache.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/Cache/Apache.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/Cache/Cache.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/Cache/Memcached.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/Cache/RAM.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/DBD.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/DBD/Pg.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/DBD/SQLite.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/DBD/mysql.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/DBI.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/Partition.pm
+%%SITE_PERL%%/Data/ObjectDriver/Driver/SimplePartition.pm
+%%SITE_PERL%%/Data/ObjectDriver/Errors.pm
+%%SITE_PERL%%/Data/ObjectDriver/Profiler.pm
+%%SITE_PERL%%/Data/ObjectDriver/SQL.pm
+@dirrmtry %%SITE_PERL%%/Data/ObjectDriver/Driver/DBD
+@dirrmtry %%SITE_PERL%%/Data/ObjectDriver/Driver/Cache
+@dirrmtry %%SITE_PERL%%/Data/ObjectDriver/Driver
+@dirrmtry %%SITE_PERL%%/Data/ObjectDriver
+@dirrmtry %%SITE_PERL%%/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ObjectDriver
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data