aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Random/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-15 15:48:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-15 15:48:53 +0000
commitf3bdde5d4437f4a5231ec94efe724c849b16d739 (patch)
tree6548f35ca8fff5064f7a7338cccb30ee27847ec0 /devel/p5-Data-Random/Makefile
parentd57c2356fba7babdd8f0e3e8e74675d33716d63e (diff)
downloadports-f3bdde5d4437f4a5231ec94efe724c849b16d739.tar.gz
ports-f3bdde5d4437f4a5231ec94efe724c849b16d739.zip
Notes
Diffstat (limited to 'devel/p5-Data-Random/Makefile')
-rw-r--r--devel/p5-Data-Random/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/devel/p5-Data-Random/Makefile b/devel/p5-Data-Random/Makefile
index a1e765e82710..85f75452faad 100644
--- a/devel/p5-Data-Random/Makefile
+++ b/devel/p5-Data-Random/Makefile
@@ -1,10 +1,12 @@
# New Ports Collection Makefile for: p5-Data-Random
# Date created: 2004-07-07
# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
# $FreeBSD$
+#
PORTNAME= Data-Random
-PORTVERSION= 0.05
+PORTVERSION= 0.06
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,23 +14,29 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for generating random data
+OPTIONS= DATE_CALC "Support for rand_date()" on \
+ GD "Support for rand_image()" off
+
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+MAN3= Data::Random.3 Data::Random::WordList.3
+
+.include <bsd.port.options.mk>
-# define WITHOUT_DATE_CALC to disable support for rand_date()
.if !defined(WITHOUT_DATE_CALC)
-EXTRA_DEPENDS+= ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
+BUILD_DEPENDS+= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
+RUN_DEPENDS+= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
.endif
-# define WITH_GD to enable support for rand_image()
.if defined(WITH_GD)
-EXTRA_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+BUILD_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
.endif
-BUILD_DEPENDS+= ${EXTRA_DEPENDS}
-RUN_DEPENDS+= ${EXTRA_DEPENDS}
+.include <bsd.port.pre.mk>
-MAN3= Data::Random.3 Data::Random::WordList.3
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
.include <bsd.port.post.mk>