aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Rx
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-20 18:03:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-20 18:03:28 +0000
commit32e5c55fcd9d12e408d579a60de120a1f446270d (patch)
treedfa7de0d8de3b90c0b727997c1e3aeb718e1b846 /devel/p5-Data-Rx
parent8b6d1382bce9d6d31fd5cab299ee7bcffdd951c7 (diff)
Notes
Diffstat (limited to 'devel/p5-Data-Rx')
-rw-r--r--devel/p5-Data-Rx/Makefile43
-rw-r--r--devel/p5-Data-Rx/distinfo2
-rw-r--r--devel/p5-Data-Rx/pkg-descr3
-rw-r--r--devel/p5-Data-Rx/pkg-plist26
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/p5-Data-Rx/Makefile b/devel/p5-Data-Rx/Makefile
new file mode 100644
index 000000000000..5c1a29e3b9b5
--- /dev/null
+++ b/devel/p5-Data-Rx/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Data-Rx
+# Date created: 2010-11-18
+# Whom: Kurt Lidl <kurt.lidl@cello.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Rx
+PORTVERSION= 0.100110
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl implementation of Rx schema system
+
+RUN_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-Number-Tolerant>=0:${PORTSDIR}/devel/p5-Number-Tolerant
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Rx.3 \
+ Data::Rx::CoreType.3 \
+ Data::Rx::CoreType::all.3 \
+ Data::Rx::CoreType::any.3 \
+ Data::Rx::CoreType::arr.3 \
+ Data::Rx::CoreType::bool.3 \
+ Data::Rx::CoreType::def.3 \
+ Data::Rx::CoreType::fail.3 \
+ Data::Rx::CoreType::int.3 \
+ Data::Rx::CoreType::map.3 \
+ Data::Rx::CoreType::nil.3 \
+ Data::Rx::CoreType::num.3 \
+ Data::Rx::CoreType::one.3 \
+ Data::Rx::CoreType::rec.3 \
+ Data::Rx::CoreType::seq.3 \
+ Data::Rx::CoreType::str.3 \
+ Data::Rx::TypeBundle.3 \
+ Data::Rx::TypeBundle::Core.3 \
+ Data::Rx::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Rx/distinfo b/devel/p5-Data-Rx/distinfo
new file mode 100644
index 000000000000..af386c66f38b
--- /dev/null
+++ b/devel/p5-Data-Rx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Rx-0.100110.tar.gz) = bbcd5a54913bc4ed649e41a7ce490cf660791474ac3789f6a994b5ae8120ab32
+SIZE (Data-Rx-0.100110.tar.gz) = 18399
diff --git a/devel/p5-Data-Rx/pkg-descr b/devel/p5-Data-Rx/pkg-descr
new file mode 100644
index 000000000000..19227cb13afc
--- /dev/null
+++ b/devel/p5-Data-Rx/pkg-descr
@@ -0,0 +1,3 @@
+Data::Rx is the perl implementation of Rx schema system.
+
+WWW: http://search.cpan.org/dist/Data-Rx/
diff --git a/devel/p5-Data-Rx/pkg-plist b/devel/p5-Data-Rx/pkg-plist
new file mode 100644
index 000000000000..5f0af5867508
--- /dev/null
+++ b/devel/p5-Data-Rx/pkg-plist
@@ -0,0 +1,26 @@
+%%SITE_PERL%%/Data/Rx.pm
+%%SITE_PERL%%/Data/Rx/CoreType.pm
+%%SITE_PERL%%/Data/Rx/CoreType/all.pm
+%%SITE_PERL%%/Data/Rx/CoreType/any.pm
+%%SITE_PERL%%/Data/Rx/CoreType/arr.pm
+%%SITE_PERL%%/Data/Rx/CoreType/bool.pm
+%%SITE_PERL%%/Data/Rx/CoreType/def.pm
+%%SITE_PERL%%/Data/Rx/CoreType/fail.pm
+%%SITE_PERL%%/Data/Rx/CoreType/int.pm
+%%SITE_PERL%%/Data/Rx/CoreType/map.pm
+%%SITE_PERL%%/Data/Rx/CoreType/nil.pm
+%%SITE_PERL%%/Data/Rx/CoreType/num.pm
+%%SITE_PERL%%/Data/Rx/CoreType/one.pm
+%%SITE_PERL%%/Data/Rx/CoreType/rec.pm
+%%SITE_PERL%%/Data/Rx/CoreType/seq.pm
+%%SITE_PERL%%/Data/Rx/CoreType/str.pm
+%%SITE_PERL%%/Data/Rx/TypeBundle.pm
+%%SITE_PERL%%/Data/Rx/TypeBundle/Core.pm
+%%SITE_PERL%%/Data/Rx/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Rx/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Rx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrm %%SITE_PERL%%/Data/Rx/TypeBundle
+@dirrm %%SITE_PERL%%/Data/Rx/CoreType
+@dirrm %%SITE_PERL%%/Data/Rx
+@dirrmtry %%SITE_PERL%%/Data