aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Structure-Util
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 20:27:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 20:27:07 +0000
commitb7fc7a0e6cee37b7c480ef39b8568e0a36f1059f (patch)
treef18b72059036d78734d3b428baefcdbe2ddb6876 /devel/p5-Data-Structure-Util
parent52039e7d35c74cd2b6919282ef4f4bbbc6c7f430 (diff)
downloadports-b7fc7a0e6cee37b7c480ef39b8568e0a36f1059f.tar.gz
ports-b7fc7a0e6cee37b7c480ef39b8568e0a36f1059f.zip
Notes
Diffstat (limited to 'devel/p5-Data-Structure-Util')
-rw-r--r--devel/p5-Data-Structure-Util/Makefile22
-rw-r--r--devel/p5-Data-Structure-Util/distinfo3
-rw-r--r--devel/p5-Data-Structure-Util/pkg-descr12
-rw-r--r--devel/p5-Data-Structure-Util/pkg-plist8
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Data-Structure-Util/Makefile b/devel/p5-Data-Structure-Util/Makefile
new file mode 100644
index 000000000000..10626465f0c6
--- /dev/null
+++ b/devel/p5-Data-Structure-Util/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Data-Structure
+# Date created: April 9 2006
+# Whom: Jon Nistor <nistor@snickers.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Structure-Util
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nistor@snickers.org
+COMMENT= Perl5 module to change the nature of data within a structure
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Structure::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Structure-Util/distinfo b/devel/p5-Data-Structure-Util/distinfo
new file mode 100644
index 000000000000..690e4d12c946
--- /dev/null
+++ b/devel/p5-Data-Structure-Util/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Structure-Util-0.11.tar.gz) = 3cbec998cd7c55b1244b3f782569b552
+SHA256 (Data-Structure-Util-0.11.tar.gz) = 718ad8d5906cf3a7e67c6d4dc7f4a5d106fa2c72c6f141731da8ae5d1736948d
+SIZE (Data-Structure-Util-0.11.tar.gz) = 14746
diff --git a/devel/p5-Data-Structure-Util/pkg-descr b/devel/p5-Data-Structure-Util/pkg-descr
new file mode 100644
index 000000000000..2db811849d2f
--- /dev/null
+++ b/devel/p5-Data-Structure-Util/pkg-descr
@@ -0,0 +1,12 @@
+Data::Structure::Util - Change nature of data within a structure
+
+Data::Structure::Util is a toolbox to manipulate the data inside
+a data structure. It can process an entire tree and perform the
+operation requested on each appropriate element.
+
+For example: It can transform all strings within a data structure
+to utf8 or transform any utf8 string back to the default encoding.
+It can remove the blessing on any reference. It can collect all
+the objects or detect if there is a circular reference.
+
+It is written in C for decent speed.
diff --git a/devel/p5-Data-Structure-Util/pkg-plist b/devel/p5-Data-Structure-Util/pkg-plist
new file mode 100644
index 000000000000..13d166dcb544
--- /dev/null
+++ b/devel/p5-Data-Structure-Util/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Structure/Util/Util.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Structure/Util/Util.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Structure/Util.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Structure/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Structure
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Data/Structure
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Data