aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Table
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-24 19:21:59 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-24 19:21:59 +0000
commit00cc21b6051fca3cf766daebbddb799ad716783a (patch)
tree14a54272f0b516150247d8f51d9143313ee74ac5 /devel/p5-Data-Table
parent0de5bb08e338b1b8b86acdbf5f9a18637041dc9b (diff)
downloadports-00cc21b6051fca3cf766daebbddb799ad716783a.tar.gz
ports-00cc21b6051fca3cf766daebbddb799ad716783a.zip
Notes
Diffstat (limited to 'devel/p5-Data-Table')
-rw-r--r--devel/p5-Data-Table/Makefile22
-rw-r--r--devel/p5-Data-Table/distinfo2
-rw-r--r--devel/p5-Data-Table/pkg-descr22
-rw-r--r--devel/p5-Data-Table/pkg-plist8
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-Data-Table/Makefile b/devel/p5-Data-Table/Makefile
new file mode 100644
index 000000000000..f5014987fe24
--- /dev/null
+++ b/devel/p5-Data-Table/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Data-Table
+# Date created: 10 November 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Table
+PORTVERSION= 1.43
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Data type related to database tables, HTML table displays, etc
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Table.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Table/distinfo b/devel/p5-Data-Table/distinfo
new file mode 100644
index 000000000000..8fb35f249336
--- /dev/null
+++ b/devel/p5-Data-Table/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Table-1.43.tar.gz) = d457e695096718edaf4fe150f20fbc99
+SIZE (Data-Table-1.43.tar.gz) = 29248
diff --git a/devel/p5-Data-Table/pkg-descr b/devel/p5-Data-Table/pkg-descr
new file mode 100644
index 000000000000..8cb57c011cce
--- /dev/null
+++ b/devel/p5-Data-Table/pkg-descr
@@ -0,0 +1,22 @@
+This perl package uses perl5 objects to make it easy for manipulating
+spreadsheet data among disk files, database, and Web publishing.
+
+A table object contains a header and a two-dimensional array of scalars.
+Three class methods Data::Table::fromCSV, Data::Table::fromTSV, and
+Data::Table::fromSQL allow users to create a table object from a CSV/TSV
+file or a database SQL selection in a snap.
+
+Table methods provide basic access, add, delete row(s) or column(s)
+operations, as well as more advanced sub-table extraction, table sorting,
+record matching via keywords or patterns, table merging, and web
+publishing. Data::Table class also provides a straightforward interface to
+other popular Perl modules such as DBI and GD::Graph.
+
+The current version of Table.pm is available at
+http://www.geocities.com/easydatabase
+
+WWW: http://search.cpan.org/dist/Data-Table
+Author: Yingyao Zhou & Guangzhou Zou <easydatabase@yahoo.com>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Data-Table/pkg-plist b/devel/p5-Data-Table/pkg-plist
new file mode 100644
index 000000000000..840b71b8fc8b
--- /dev/null
+++ b/devel/p5-Data-Table/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Data/Table.pm
+%%SITE_PERL%%/auto/Data/Table/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Table/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Table
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@dirrm %%SITE_PERL%%/auto/Data/Table
+@unexec rmdir %D/%%SITE_PERL%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true