aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Visitor/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-03-26 21:05:51 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-03-26 21:05:51 +0000
commit9efc48ac337903cac889ca12d3251181f6d04d8b (patch)
treee417ddc8bf3c49ed079db4c3cb3de4133dd5996f /devel/p5-Data-Visitor/Makefile
parent57bed600c8d187533b2962e3b2bde5f36342f9ec (diff)
This module is a simple visitor implementation for Perl values.
It has a main dispatcher method, visit, which takes a single perl value and then calls the methods appropriate for that value. WWW: http://search.cpan.org/dist/Data-Visitor/ PR: ports/94954 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=158204
Diffstat (limited to 'devel/p5-Data-Visitor/Makefile')
-rw-r--r--devel/p5-Data-Visitor/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-Data-Visitor/Makefile b/devel/p5-Data-Visitor/Makefile
new file mode 100644
index 000000000000..3ca20920bc3b
--- /dev/null
+++ b/devel/p5-Data-Visitor/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Data-Visitor
+# Date created: 26 Mar 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Visitor
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Visitor style traversal of Perl data structures
+
+BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Visitor.3 \
+ Data::Visitor::Callback.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>