aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Astro/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-30 17:24:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-30 17:24:33 +0000
commitfa8642ee907f97dc5af6069c14a631c5a2381365 (patch)
tree0cb9fb306f81376cc7a204728254c04b6b51a7fd /devel/p5-DateTime-Astro/Makefile
parent4b7c37750e8ffd532e5cf087443a6677d744c968 (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Astro/Makefile')
-rw-r--r--devel/p5-DateTime-Astro/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Astro/Makefile b/devel/p5-DateTime-Astro/Makefile
new file mode 100644
index 000000000000..85951b2adbec
--- /dev/null
+++ b/devel/p5-DateTime-Astro/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-DateTime-Astro
+# Date created: 2011-11-29
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Astro
+PORTVERSION= 0.99.999
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DMAKI
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}_03
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Functions For Astromical Calendars
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
+LIB_DEPENDS= mpfr:${PORTSDIR}/math/mpfr
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAN3= DateTime::Astro.3 \
+ DateTime::Event::SolarTerm.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e '/^INC = / s|$$| -I${LOCALBASE}/include|' ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>