aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Astro
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-30 17:24:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-30 17:24:33 +0000
commitfa8642ee907f97dc5af6069c14a631c5a2381365 (patch)
tree0cb9fb306f81376cc7a204728254c04b6b51a7fd /devel/p5-DateTime-Astro
parent4b7c37750e8ffd532e5cf087443a6677d744c968 (diff)
downloadports-fa8642ee907f97dc5af6069c14a631c5a2381365.tar.gz
ports-fa8642ee907f97dc5af6069c14a631c5a2381365.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Astro')
-rw-r--r--devel/p5-DateTime-Astro/Makefile44
-rw-r--r--devel/p5-DateTime-Astro/distinfo2
-rw-r--r--devel/p5-DateTime-Astro/pkg-descr13
-rw-r--r--devel/p5-DateTime-Astro/pkg-plist11
4 files changed, 70 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Astro/Makefile b/devel/p5-DateTime-Astro/Makefile
new file mode 100644
index 000000000000..85951b2adbec
--- /dev/null
+++ b/devel/p5-DateTime-Astro/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-DateTime-Astro
+# Date created: 2011-11-29
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Astro
+PORTVERSION= 0.99.999
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DMAKI
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}_03
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Functions For Astromical Calendars
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
+LIB_DEPENDS= mpfr:${PORTSDIR}/math/mpfr
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0:${PORTSDIR}/devel/p5-DateTime-Set
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAN3= DateTime::Astro.3 \
+ DateTime::Event::SolarTerm.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e '/^INC = / s|$$| -I${LOCALBASE}/include|' ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Astro/distinfo b/devel/p5-DateTime-Astro/distinfo
new file mode 100644
index 000000000000..aeb450baed1c
--- /dev/null
+++ b/devel/p5-DateTime-Astro/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DateTime-Astro-0.99999_03.tar.gz) = 7a1ad554bf2e4b107414c72e53561f046261602292fe11ba107e73d82cdf3700
+SIZE (DateTime-Astro-0.99999_03.tar.gz) = 95982
diff --git a/devel/p5-DateTime-Astro/pkg-descr b/devel/p5-DateTime-Astro/pkg-descr
new file mode 100644
index 000000000000..2edff346bb65
--- /dev/null
+++ b/devel/p5-DateTime-Astro/pkg-descr
@@ -0,0 +1,13 @@
+DateTime::Astro implements functions used in astronomical calendars:
+- Solar Longitude
+- Solar Terms
+- Lunar Longitude
+- New Moons
+... etc
+
+This module is best used in environments where a C compiler and the MPFR
+arbitrary precision math library is installed. It can fallback to using
+Math::BigInt, but that would pretty much render it useless because of its speed
+and loss of accuracy that may creep up while doing Perl to C struct conversions.
+
+WWW: http://search.cpan.org/dist/DateTime-Astro/
diff --git a/devel/p5-DateTime-Astro/pkg-plist b/devel/p5-DateTime-Astro/pkg-plist
new file mode 100644
index 000000000000..9c18f1abc53e
--- /dev/null
+++ b/devel/p5-DateTime-Astro/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Astro.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/AstroPP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/AstroXS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Event/SolarTerm.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Astro/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Astro/Astro.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Astro/Astro.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Astro
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Event
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/DateTime