aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Event-Cron
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-06 09:54:05 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-06 09:54:05 +0000
commit24da8677d88e824c6b5d47c56a44f730d8009d68 (patch)
treeaff835302bd4dbce99f39f9acd658bf4b6afe245 /devel/p5-DateTime-Event-Cron
parent75b0e6fd474275813980082b21c194d16f36b83e (diff)
downloadports-24da8677d88e824c6b5d47c56a44f730d8009d68.tar.gz
ports-24da8677d88e824c6b5d47c56a44f730d8009d68.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Event-Cron')
-rw-r--r--devel/p5-DateTime-Event-Cron/Makefile34
-rw-r--r--devel/p5-DateTime-Event-Cron/distinfo1
-rw-r--r--devel/p5-DateTime-Event-Cron/pkg-descr4
-rw-r--r--devel/p5-DateTime-Event-Cron/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Event-Cron/Makefile b/devel/p5-DateTime-Event-Cron/Makefile
new file mode 100644
index 000000000000..e28dc6bb75b1
--- /dev/null
+++ b/devel/p5-DateTime-Event-Cron/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-DateTime-Event-Cron
+# Date created: 1 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Event-Cron
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= DateTime extension for generating recurrence sets from crontab
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
+ ${SITE_PERL}/Set/Crontab.pm:${PORTSDIR}/devel/p5-Set-Crontab
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Event::Cron.3
+
+.include <bsd.port.pre.mk>
+
+# p5-DateTime-Set requires perl 5.6 or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Event-Cron/distinfo b/devel/p5-DateTime-Event-Cron/distinfo
new file mode 100644
index 000000000000..af4fedc0a260
--- /dev/null
+++ b/devel/p5-DateTime-Event-Cron/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Event-Cron-0.03.tar.gz) = 99c281cc4b67c08c8243cc274d06e1fe
diff --git a/devel/p5-DateTime-Event-Cron/pkg-descr b/devel/p5-DateTime-Event-Cron/pkg-descr
new file mode 100644
index 000000000000..660b3881b30a
--- /dev/null
+++ b/devel/p5-DateTime-Event-Cron/pkg-descr
@@ -0,0 +1,4 @@
+DateTime::Event::Cron generated DateTime events or DateTime::Set objects based
+on crontab-style entries.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Event-Cron/pkg-plist b/devel/p5-DateTime-Event-Cron/pkg-plist
new file mode 100644
index 000000000000..6480f32ca3b1
--- /dev/null
+++ b/devel/p5-DateTime-Event-Cron/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Event/Cron.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Event/Cron/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Event/Cron
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Event 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Event 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true